summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2016-11-09 16:17:13 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2016-11-09 16:19:03 +0100
commit24b04f5e4e1ef9d16d1437802655dbc124ba5d54 (patch)
tree47bbba9604e1bdbb023234245c57342c42fb18f8 /dev-util/molecule-core/molecule-core-1.0.2-r1.ebuild
parentdev-util/molecule: eapi bump, fix headers, cleanup (diff)
downloadgentoo-24b04f5e4e1ef9d16d1437802655dbc124ba5d54.tar.gz
gentoo-24b04f5e4e1ef9d16d1437802655dbc124ba5d54.tar.bz2
gentoo-24b04f5e4e1ef9d16d1437802655dbc124ba5d54.zip
dev-util/molecule-core: revision bump
* migrate to python-r1 eclass and EAPI=6 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=599308 Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-util/molecule-core/molecule-core-1.0.2-r1.ebuild')
-rw-r--r--dev-util/molecule-core/molecule-core-1.0.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/molecule-core/molecule-core-1.0.2-r1.ebuild b/dev-util/molecule-core/molecule-core-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..0ac7754415ac
--- /dev/null
+++ b/dev-util/molecule-core/molecule-core-1.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1
+
+DESCRIPTION="Sabayon distro-agnostic images build tool"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="!<dev-util/molecule-1
+ sys-process/lsof"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install
+}