summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/mono-debugger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/mono-debugger')
-rw-r--r--dev-util/mono-debugger/Manifest1
-rw-r--r--dev-util/mono-debugger/files/mono-debugger-2.10-glib2.32.patch11
-rw-r--r--dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch97
-rw-r--r--dev-util/mono-debugger/metadata.xml5
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.10.ebuild49
5 files changed, 163 insertions, 0 deletions
diff --git a/dev-util/mono-debugger/Manifest b/dev-util/mono-debugger/Manifest
new file mode 100644
index 000000000000..c8dc52ddb89c
--- /dev/null
+++ b/dev-util/mono-debugger/Manifest
@@ -0,0 +1 @@
+DIST mono-debugger-2.10.tar.bz2 1424640 SHA256 6896ae43ab7c8b302364e95725b7675b1642e77d22bcf96b5990c01652d23715 SHA512 a71d20b76c29b3b2dab06112c6c34ffe94a21bc4cef4693a177a62b23da0b728667075918cd8919e370a6c37debfd0e828ac4439da0051900420a59cb5802cc6 WHIRLPOOL af46221d3bbd6c9bf3f03da8111dba3e78f50821ef5019c2b5f5e172c72c9d6538692536c48f08d0c84b7035f45868a3c0fe4b3c8cf9a1f3bba24200bff2b711
diff --git a/dev-util/mono-debugger/files/mono-debugger-2.10-glib2.32.patch b/dev-util/mono-debugger/files/mono-debugger-2.10-glib2.32.patch
new file mode 100644
index 000000000000..ea0538a51def
--- /dev/null
+++ b/dev-util/mono-debugger/files/mono-debugger-2.10-glib2.32.patch
@@ -0,0 +1,11 @@
+diff -uNr mono-debugger-2.10.old/sysdeps/server/breakpoints.c mono-debugger-2.10/sysdeps/server/breakpoints.c
+--- mono-debugger-2.10.old/sysdeps/server/breakpoints.c 2011-01-13 23:41:31.000000000 +0100
++++ mono-debugger-2.10/sysdeps/server/breakpoints.c 2011-11-12 15:46:57.909192866 +0100
+@@ -1,6 +1,6 @@
+ #include <server.h>
+ #include <breakpoints.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <sys/stat.h>
+ #include <signal.h>
+ #ifdef HAVE_UNISTD_H
diff --git a/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch b/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch
new file mode 100644
index 000000000000..3925606c1fde
--- /dev/null
+++ b/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch
@@ -0,0 +1,97 @@
+diff --git a/configure.in b/configure.in
+index c643e64..402be56 100644
+--- a/configure.in
++++ b/configure.in
+@@ -64,6 +64,19 @@ case "$host" in
+ esac
+ AC_MSG_RESULT(ok)
+
++AC_ARG_WITH([system-libbfd],
++ AS_HELP_STRING([--with-system-libbfd], [Use the system copy of libbfd and libopcodes.]))
++
++AS_IF([test "x$with_system_libbfd" = "xyes"],
++ [
++ AC_CHECK_HEADERS([bfd.h], [], [AC_MSG_ERROR([Missing bfd.h header])])
++ AC_CHECK_LIB([bfd], [bfd_init], [:], [AC_MSG_ERROR([Missing libbfd library])])
++ AC_CHECK_LIB([opcodes], [init_disassemble_info], [:], [AC_MSG_ERROR([Missing libopcodes library])])
++ AC_CHECK_MEMBERS([asection.rawsize], [], [], [[#include <bfd.h>]])
++ ])
++
++AM_CONDITIONAL([SYSTEM_LIBBFD], [test "x$with_system_libbfd" = "xyes"])
++
+ AC_ARG_WITH(bfd-target,
+ [ --with-bfd-target Manually override the BFD target],
+ if test x$with_bfd_target != "x"; then
+diff --git a/sysdeps/Makefile.am b/sysdeps/Makefile.am
+index 017026f..f63c181 100644
+--- a/sysdeps/Makefile.am
++++ b/sysdeps/Makefile.am
+@@ -1 +1,5 @@
++if !SYSTEM_LIBBFD
+ SUBDIRS = bfd server
++else
++SUBDIRS = server
++endif
+diff --git a/sysdeps/server/Makefile.am b/sysdeps/server/Makefile.am
+index dad57ab..8e7ac68 100644
+--- a/sysdeps/server/Makefile.am
++++ b/sysdeps/server/Makefile.am
+@@ -6,10 +6,9 @@ libmonodebuggerbfdglue_la_SOURCES = \
+ bfdglue.c \
+ bfdglue.h
+
++if !SYSTEM_LIBBFD
+ libmonodebuggerbfdglue_la_LIBADD = \
+ ../../sysdeps/bfd/opcodes/libopcodes.la ../../sysdeps/bfd/libbfd.la
+-libmonodebuggerbfdglue_la_LDFLAGS = \
+- -no-undefined -module -export-dynamic -shared
+
+ libmonodebuggerbfdglue_la_CPPFLAGS = \
+ -I$(top_srcdir)/sysdeps/bfd \
+@@ -17,6 +16,17 @@ libmonodebuggerbfdglue_la_CPPFLAGS = \
+ -I$(top_srcdir)/sysdeps/bfd/opcodes \
+ @SERVER_DEPENDENCIES_CFLAGS@ @server_cflags@
+
++else
++libmonodebuggerbfdglue_la_LIBADD = -lopcodes -lbfd
++
++libmonodebuggerbfdglue_la_CPPFLAGS = \
++ @SERVER_DEPENDENCIES_CFLAGS@ @server_cflags@
++
++endif
++
++libmonodebuggerbfdglue_la_LDFLAGS = \
++ -no-undefined -module -export-dynamic -shared
++
+ EXTRA_libmonodebuggerserver_la_SOURCES = \
+ i386-arch.c \
+ i386-arch.h \
+diff --git a/sysdeps/server/bfdglue.c b/sysdeps/server/bfdglue.c
+index 9a741ac..e2138e7 100644
+--- a/sysdeps/server/bfdglue.c
++++ b/sysdeps/server/bfdglue.c
+@@ -1,3 +1,5 @@
++#include <config.h>
++
+ #include <bfdglue.h>
+ #include <signal.h>
+ #include <string.h>
+@@ -246,7 +248,11 @@ bfd_glue_get_errormsg (void)
+ guint32
+ bfd_glue_get_section_size (asection *p)
+ {
++#ifdef HAVE_ASECTION_RAWSIZE
++ return p->rawsize ? p->rawsize : p->size;
++#else
+ return p->_raw_size;
++#endif
+ }
+
+ BfdGlueSectionFlags
+@@ -350,4 +356,4 @@ guint64
+ bfd_glue_get_start_address (bfd *abfd)
+ {
+ return bfd_get_start_address (abfd);
+-}
+\ No newline at end of file
++}
diff --git a/dev-util/mono-debugger/metadata.xml b/dev-util/mono-debugger/metadata.xml
new file mode 100644
index 000000000000..e85974a7fa17
--- /dev/null
+++ b/dev-util/mono-debugger/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-util/mono-debugger/mono-debugger-2.10.ebuild b/dev-util/mono-debugger/mono-debugger-2.10.ebuild
new file mode 100644
index 000000000000..d3afab099b90
--- /dev/null
+++ b/dev-util/mono-debugger/mono-debugger-2.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit go-mono mono autotools flag-o-matic eutils
+
+DESCRIPTION="Debugger for .NET managed and unmanaged applications"
+HOMEPAGE="http://www.mono-project.com/"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+# bah, tests fail. Needs to be fixed ...
+RESTRICT="test"
+
+#Bundles jay
+# Binutils is needed for libbfd
+RDEPEND="!!=dev-lang/mono-2.2
+ sys-devel/binutils
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ !dev-lang/mercury"
+
+src_prepare() {
+ go-mono_src_prepare
+
+ epatch "${FILESDIR}/${P}-glib2.32.patch"
+
+ # Allow compilation against system libbfd, bnc#662581
+ epatch "${FILESDIR}/${PN}-2.8-system-bfd.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # Let's go for extra safety to avoid runtime errors, until
+ # upstream applies it.
+ append-ldflags -Wl,--no-undefined
+
+ go-mono_src_configure \
+ --with-system-libbfd \
+ --disable-static
+}
+
+src_compile() {
+ emake -j1
+}