summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-04-03 14:48:48 -0400
committerMike Gilbert <floppym@gentoo.org>2019-04-03 14:48:48 -0400
commit0553acbb90e9fcd50f169a257d1d220f4c5058e9 (patch)
treef98c1719c59998b6021bfd122e4afb9dec11d36c /dev-util/ninja/ninja-9999.ebuild
parentdev-python/redis-py: 3.2.1 bump (diff)
downloadgentoo-0553acbb90e9fcd50f169a257d1d220f4c5058e9.tar.gz
gentoo-0553acbb90e9fcd50f169a257d1d220f4c5058e9.tar.bz2
gentoo-0553acbb90e9fcd50f169a257d1d220f4c5058e9.zip
dev-util/ninja: bump to 1.9.0
Closes: https://bugs.gentoo.org/682420 Package-Manager: Portage-2.3.62_p4, Repoman-2.3.12_p87 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-util/ninja/ninja-9999.ebuild')
-rw-r--r--dev-util/ninja/ninja-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-util/ninja/ninja-9999.ebuild b/dev-util/ninja/ninja-9999.ebuild
index 0f378c4dd3aa..8eb95d5047f6 100644
--- a/dev-util/ninja/ninja-9999.ebuild
+++ b/dev-util/ninja/ninja-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 2012-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
inherit bash-completion-r1 elisp-common python-any-r1 toolchain-funcs
@@ -11,7 +11,10 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ninja-build/ninja.git"
else
- SRC_URI="https://github.com/ninja-build/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KITWARE_VERSION="1.9.0.g99df1.kitware.dyndep-1.jobserver-1"
+ MY_P="ninja-${KITWARE_VERSION}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/Kitware/ninja/archive/v${KITWARE_VERSION}.tar.gz -> ${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
fi
@@ -47,9 +50,11 @@ run_for_build() {
if tc-is-cross-compiler; then
local -x AR=$(tc-getBUILD_AR)
local -x CXX=$(tc-getBUILD_CXX)
- local -x CFLAGS=${BUILD_CXXFLAGS}
+ local -x CFLAGS=
+ local -x CXXFLAGS=${BUILD_CXXFLAGS}
local -x LDFLAGS=${BUILD_LDFLAGS}
fi
+ echo "$@" >&2
"$@"
}
@@ -59,7 +64,7 @@ src_compile() {
# configure.py uses CFLAGS instead of CXXFLAGS
export CFLAGS=${CXXFLAGS}
- run_for_build "${PYTHON}" configure.py --bootstrap --verbose || die
+ run_for_build ${EPYTHON} configure.py --bootstrap --verbose || die
if tc-is-cross-compiler; then
mv ninja ninja-build || die
@@ -82,7 +87,7 @@ src_test() {
if ! tc-is-cross-compiler; then
# Bug 485772
ulimit -n 2048
- ./ninja-build -v ninja_test || die
+ ./ninja -v ninja_test || die
./ninja_test || die
fi
}