summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-05-16 00:17:10 -0400
committerPatrice Clement <monsieurp@gentoo.org>2017-05-25 22:54:49 +0200
commit449a25488af2de2cda045d3073bb64d0deec5f05 (patch)
tree59becb1fba6cefa72a501472493f5847155c2bfc /dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild
parentmail-filter/libdkim: fix building with GCC-6. (diff)
downloadgentoo-449a25488af2de2cda045d3073bb64d0deec5f05.tar.gz
gentoo-449a25488af2de2cda045d3073bb64d0deec5f05.tar.bz2
gentoo-449a25488af2de2cda045d3073bb64d0deec5f05.zip
dev-util/open-vcdiff: fix building with GCC-6.
Gentoo-Bug: https://bugs.gentoo.org/594334 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4639
Diffstat (limited to 'dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild')
-rw-r--r--dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild b/dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..18324677305e
--- /dev/null
+++ b/dev-util/open-vcdiff/open-vcdiff-0.8.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An encoder/decoder for the VCDIFF (RFC3284) format"
+HOMEPAGE="https://github.com/google/open-vcdiff"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}