summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2022-02-11 19:14:23 +0000
committerZac Medico <zmedico@gentoo.org>2022-02-12 08:52:46 -0800
commit952a8d9b1b1031d0fe20f78a39845ac9cba19707 (patch)
tree274b422e55288678ebc78befee7897336371d7bc /dev-util/ostree
parentdev-util/ostree: Removed deletion of 15_ostree script (diff)
downloadgentoo-952a8d9b1b1031d0fe20f78a39845ac9cba19707.tar.gz
gentoo-952a8d9b1b1031d0fe20f78a39845ac9cba19707.tar.bz2
gentoo-952a8d9b1b1031d0fe20f78a39845ac9cba19707.zip
dev-util/ostree: Set --with-modern-grub configure flag
Set --with-modern-grub configure flag so that 16 suffix of the GRUB configuration generation code is not used (breaks on UEFI installs): https://github.com/ostreedev/ostree/blob/main/src/libostree/ostree-bootloader-grub2.c#L29 Also set --with-grub2-mkconfig-path to the actual name the Gentoo binary has. Closes: https://github.com/gentoo/gentoo/pull/24124 Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util/ostree')
-rw-r--r--dev-util/ostree/ostree-2021.3-r2.ebuild2
-rw-r--r--dev-util/ostree/ostree-2021.4-r1.ebuild2
-rw-r--r--dev-util/ostree/ostree-2021.5.ebuild2
-rw-r--r--dev-util/ostree/ostree-2022.1.ebuild2
4 files changed, 8 insertions, 0 deletions
diff --git a/dev-util/ostree/ostree-2021.3-r2.ebuild b/dev-util/ostree/ostree-2021.3-r2.ebuild
index 81adc59544d9..b422addea358 100644
--- a/dev-util/ostree/ostree-2021.3-r2.ebuild
+++ b/dev-util/ostree/ostree-2021.3-r2.ebuild
@@ -73,6 +73,8 @@ src_configure() {
local econfargs=(
--enable-man
--enable-shared
+ --with-grub2-mkconfig-path=grub-mkconfig
+ --with-modern-grub
$(use_with archive libarchive)
$(use_with curl)
$(use_with dracut)
diff --git a/dev-util/ostree/ostree-2021.4-r1.ebuild b/dev-util/ostree/ostree-2021.4-r1.ebuild
index 4e256a7ed7c6..d8ab1b23e9b9 100644
--- a/dev-util/ostree/ostree-2021.4-r1.ebuild
+++ b/dev-util/ostree/ostree-2021.4-r1.ebuild
@@ -74,6 +74,8 @@ src_configure() {
local econfargs=(
--enable-man
--enable-shared
+ --with-grub2-mkconfig-path=grub-mkconfig
+ --with-modern-grub
$(use_with archive libarchive)
$(use_with curl)
$(use_with dracut dracut yesbutnoconf) #816867
diff --git a/dev-util/ostree/ostree-2021.5.ebuild b/dev-util/ostree/ostree-2021.5.ebuild
index 4e256a7ed7c6..d8ab1b23e9b9 100644
--- a/dev-util/ostree/ostree-2021.5.ebuild
+++ b/dev-util/ostree/ostree-2021.5.ebuild
@@ -74,6 +74,8 @@ src_configure() {
local econfargs=(
--enable-man
--enable-shared
+ --with-grub2-mkconfig-path=grub-mkconfig
+ --with-modern-grub
$(use_with archive libarchive)
$(use_with curl)
$(use_with dracut dracut yesbutnoconf) #816867
diff --git a/dev-util/ostree/ostree-2022.1.ebuild b/dev-util/ostree/ostree-2022.1.ebuild
index 18f57563e889..6993c19e5db7 100644
--- a/dev-util/ostree/ostree-2022.1.ebuild
+++ b/dev-util/ostree/ostree-2022.1.ebuild
@@ -74,6 +74,8 @@ src_configure() {
local econfargs=(
--enable-man
--enable-shared
+ --with-grub2-mkconfig-path=grub-mkconfig
+ --with-modern-grub
$(use_with archive libarchive)
$(use_with curl)
$(use_with dracut dracut yesbutnoconf) #816867