summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-09-19 14:14:34 -0700
committerZac Medico <zmedico@gentoo.org>2021-09-19 14:52:24 -0700
commitfe4eb579dd11b777fb59aa67d965df1d55c872f1 (patch)
treed4cf00287355455f78a878c03269e5456b3645cd /dev-util/ostree
parentsci-libs/gts: Keyword 20121130 for ~m68k (diff)
downloadgentoo-fe4eb579dd11b777fb59aa67d965df1d55c872f1.tar.gz
gentoo-fe4eb579dd11b777fb59aa67d965df1d55c872f1.tar.bz2
gentoo-fe4eb579dd11b777fb59aa67d965df1d55c872f1.zip
dev-util/ostree: Bump to version 2021.4
Also enable http2 by default as suggested in bug #801037. Closes: https://bugs.gentoo.org/801037 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util/ostree')
-rw-r--r--dev-util/ostree/Manifest1
-rw-r--r--dev-util/ostree/ostree-2021.4.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/dev-util/ostree/Manifest b/dev-util/ostree/Manifest
index cb2f4fc7ecdc..42a0a3d6b6ba 100644
--- a/dev-util/ostree/Manifest
+++ b/dev-util/ostree/Manifest
@@ -3,3 +3,4 @@ DIST ostree-2020.6.tar.xz 2014456 BLAKE2B 97d84c6838993edfbabb598bce800332ab1c8b
DIST ostree-2020.7.tar.xz 2022004 BLAKE2B 2113117ce8553b7ffcfea17e1cb3a9c697d39b4933b48c30729af72fc833bb00f39e7e3a327efeebaac1df307b1f62ccf16a7772e12ad77737e2219c87623824 SHA512 f42dca3c9e1810c0421ab99588f27c625733b71ef811534b66e0c0c4afafbad5bf475e08feaf87c2f8414c38f127fd344adbb57a4b75001077aedbfe92af3706
DIST ostree-2020.8.tar.xz 2081080 BLAKE2B e856f9642db9fd16e96d6bdc9b3f3be93989458d72258c4586e5a49e67c197d0b7b20cefd0b5a28d77dee986db42ae5584d2894005ede654b8320402aa3af367 SHA512 2523f5742c4472f8e64614bb99edc5aec1a8f8a837b54f67efba9760aefc3385014e1296c9246ac81b361f4588deb4794768a231bf8f338c24a14255ab63da04
DIST ostree-2021.3.tar.xz 2089804 BLAKE2B 5df33b676173b1ec08ac7592d4ddf8e3bfdcd84df1b3ce19e2f24c85780fed1f210b8adce1baf4ec87869c72984502276bf6e5a72268daaae6ce9b3d6dc6f88b SHA512 0df0d8f9bd82b16562dd5146997eddfb7cb6cffc1886601307d97a1cb1dc926bda7d0c899db26c974ed0dff1012dee11937e47c11c4d03307fa3d2d430adc60e
+DIST ostree-2021.4.tar.xz 2048424 BLAKE2B 386ed38f6dc8035a429505d8392682f739bc9a57a8cf9d7960942cd0ff0b61eee314116866c3b520d802a3f16f6dfecd1ea45a7b1d44cac8d065ad56a1ed2c2f SHA512 9bde7281afa456b30253149639854f579c1f1bdf6c429059eeb69042515b5ebfdf6426b4c9780ca8e700a11f0ec05cfc03e48baa8d0858ddbca7d3942aab9bbd
diff --git a/dev-util/ostree/ostree-2021.4.ebuild b/dev-util/ostree/ostree-2021.4.ebuild
new file mode 100644
index 000000000000..4914f0692b9e
--- /dev/null
+++ b/dev-util/ostree/ostree-2021.4.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostreedev.github.io/ostree/"
+SRC_URI="https://github.com/ostreedev/ostree/releases/download/v${PV}/lib${P}.tar.xz -> ${P}.tar.xz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="archive +curl doc dracut gnutls +gpg grub +http2 httpd introspection libmount selinux sodium ssl +soup systemd zeroconf"
+RESTRICT+=" test"
+REQUIRED_USE="
+ http2? ( curl )
+ httpd? ( || ( curl soup ) )
+"
+
+COMMON_DEPEND="
+ app-arch/xz-utils
+ dev-libs/libassuan
+ dev-libs/glib:2
+ >=sys-fs/fuse-2.9.2:0
+ sys-libs/zlib
+ archive? ( app-arch/libarchive:= )
+ curl? ( net-misc/curl )
+ dracut? ( sys-kernel/dracut )
+ gpg? (
+ app-crypt/gpgme
+ dev-libs/libgpg-error
+ )
+ grub? ( sys-boot/grub:2= )
+ introspection? ( dev-libs/gobject-introspection )
+ libmount? ( sys-apps/util-linux )
+ selinux? ( sys-libs/libselinux )
+ sodium? ( >=dev-libs/libsodium-1.0.14:= )
+ soup? ( net-libs/libsoup:2.4 )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ )
+ systemd? ( sys-apps/systemd:0= )
+ zeroconf? ( net-dns/avahi[dbus] )"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ doc? ( dev-util/gtk-doc )"
+
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+S="${WORKDIR}/lib${P}"
+
+src_prepare() {
+ sed -Ee 's:(XSLT_STYLESHEET = ).*:\1/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' \
+ -i Makefile.in Makefile-man.am || die
+ eautoreconf
+ default
+}
+
+src_configure() {
+ local econfargs=(
+ --enable-man
+ --enable-shared
+ $(use_with archive libarchive)
+ $(use_with curl)
+ $(use_with dracut)
+ $(use_enable doc gtk-doc)
+ $(usex introspection --enable-introspection={,} yes no)
+ $(use_with gpg gpgme)
+ $(use_enable http2)
+ $(use_enable httpd trivial-httpd-cmdline)
+ $(use_with selinux )
+ $(use_with soup)
+ $(use_with libmount)
+ $(use ssl && { use gnutls && echo --with-crypto=gnutls || echo --with-crypto=openssl; })
+ $(use_with sodium ed25519-libsodium)
+ $(use_with systemd libsystemd)
+ $(use_with zeroconf avahi)
+ )
+
+ if use systemd; then
+ econfargs+=(--with-systemdsystemunitdir="$(systemd_get_systemunitdir)")
+ fi
+
+ unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm -f "${ED}/etc/grub.d/15_ostree"
+}