summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Molik <dan@danmolik.com>2019-10-04 06:17:54 -0400
committerManuel Rüger <mrueg@gentoo.org>2019-10-23 15:18:37 +0200
commit38fa652bb6eea2d62fea79ea545645c049da3385 (patch)
tree8048f25bd48496f138b24e11201d5cf047c132ba /dev-util/packer/packer-1.4.4.ebuild
parentapp-admin/terraform: clean up old versions of Terraform (diff)
downloadgentoo-38fa652bb6eea2d62fea79ea545645c049da3385.tar.gz
gentoo-38fa652bb6eea2d62fea79ea545645c049da3385.tar.bz2
gentoo-38fa652bb6eea2d62fea79ea545645c049da3385.zip
dev-util/packer: version bump to 1.4.4 and update
LICENSE has been update to include dependencies Tested with go 1.12 and 1.13 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Dan Molik <dan@danmolik.com> Tested-by: Dan Molik <dan@danmolik.com> Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'dev-util/packer/packer-1.4.4.ebuild')
-rw-r--r--dev-util/packer/packer-1.4.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/packer/packer-1.4.4.ebuild b/dev-util/packer/packer-1.4.4.ebuild
new file mode 100644
index 000000000000..a361a43a1fa3
--- /dev/null
+++ b/dev-util/packer/packer-1.4.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-base go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+
+EGO_PN="github.com/hashicorp/packer"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 icu imagemagick ISC JSON MIT MPL-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=""
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+ GOCACHE="${T}/go-cache" go build \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}