summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-11-07 16:16:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-11-07 16:16:48 +0000
commit3935126f0bda0fbc93998d58e61daa0e18385c15 (patch)
tree3d1b0518a49d6ef50b26c57eac58713fc9e170f3 /dev-util/pahole
parentdev-libs/qtkeychain: 0.13.0 version bump (diff)
downloadgentoo-3935126f0bda0fbc93998d58e61daa0e18385c15.tar.gz
gentoo-3935126f0bda0fbc93998d58e61daa0e18385c15.tar.bz2
gentoo-3935126f0bda0fbc93998d58e61daa0e18385c15.zip
dev-util/pahole: Bump to 1.22, add live ebuild
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-util/pahole')
-rw-r--r--dev-util/pahole/Manifest1
-rw-r--r--dev-util/pahole/pahole-1.22.ebuild52
-rw-r--r--dev-util/pahole/pahole-9999.ebuild44
3 files changed, 97 insertions, 0 deletions
diff --git a/dev-util/pahole/Manifest b/dev-util/pahole/Manifest
index ba18f4d0c77c..795a1994d309 100644
--- a/dev-util/pahole/Manifest
+++ b/dev-util/pahole/Manifest
@@ -1,2 +1,3 @@
DIST dwarves-1.20.tar.xz 688728 BLAKE2B c57f390f7e1d20c861a4acb8cd7fe238a3f7c3f2d915d96fc051dba2587942e8fabfa4f524d18555c486863fa02bc4ab63d90e90d477f376dc5e547aa36cccac SHA512 306bb74c498527a5a9bdae4d304e90511336cab627d9acad5237d93cbb48efe11dbca4418c540fa03e3ecdd168ce224cabe9fd2f6fbb50520d0dd17741c80817
DIST dwarves-1.21.tar.xz 910480 BLAKE2B b6dcdaf008a7714838904b0bc1050e6af4617e00e168f45a3f1a5d4611a05c898182f3395b2f10478240e05c22ce82a3a7381a1ea7ab41684e3b05ea6e73620c SHA512 69f510025f5790a004c356546f7d92996ad84c4ff1636876b48f1c7d81bf66c83da70f11a1912d65b46f81bea79418782021396a018e74baae5cad9221af14e1
+DIST dwarves-1.22.tar.xz 922016 BLAKE2B 79ba94bcbec6ddc9ebcc6d9e72ed63c8704ca9a97bb3df1910114e89cdd4e7cc75024e4281f15f06be8f5b4656dd957a44d561a16beff1af14d8c7dc32fbd184 SHA512 d45b19505cd59eb2cbb42304ab599661355a4085262cb202757822ec1c05476c851dea85e922f9421efb8a978ab475a6a6545757c6ab080f13ac77c5f7186606
diff --git a/dev-util/pahole/pahole-1.22.ebuild b/dev-util/pahole/pahole-1.22.ebuild
new file mode 100644
index 000000000000..6e645bb8300e
--- /dev/null
+++ b/dev-util/pahole/pahole-1.22.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit multilib cmake python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.178
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+MY_PN=dwarves
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/${MY_PN}/${MY_P}.tar.xz"
+else
+ SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-python-import.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+ python_fix_shebang ostra/ostra-cg ostra/python/ostra.py
+}
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake_src_install
+}
diff --git a/dev-util/pahole/pahole-9999.ebuild b/dev-util/pahole/pahole-9999.ebuild
new file mode 100644
index 000000000000..7ce8b9b051bf
--- /dev/null
+++ b/dev-util/pahole/pahole-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit multilib cmake python-single-r1 git-r3
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/pahole/pahole.git"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.178
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOCS=( README README.ctracer NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-python-import.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+ python_fix_shebang ostra/ostra-cg ostra/python/ostra.py
+}
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake_src_install
+}