summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-12-16 23:18:37 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-12-16 23:18:37 +0000
commit506287d87221682c4a766467388e205c9b716afd (patch)
tree3f10d40a4f749e6e493b8fe421a88137cbc128a1 /dev-util/patchelf
parentgames-board/xskat: EAPI7->8, remove imake, use valid icon format (diff)
downloadgentoo-506287d87221682c4a766467388e205c9b716afd.tar.gz
gentoo-506287d87221682c4a766467388e205c9b716afd.tar.bz2
gentoo-506287d87221682c4a766467388e205c9b716afd.zip
dev-util/patchelf: Version bump to 0.14.3
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-util/patchelf')
-rw-r--r--dev-util/patchelf/Manifest1
-rw-r--r--dev-util/patchelf/patchelf-0.14.3.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/patchelf/Manifest b/dev-util/patchelf/Manifest
index 2eefbfb21056..6393cc448f39 100644
--- a/dev-util/patchelf/Manifest
+++ b/dev-util/patchelf/Manifest
@@ -1,3 +1,4 @@
DIST patchelf-0.10.tar.bz2 158604 BLAKE2B 6aed9c2e7f37ff0330ca517a9491c46a93212140367b720bf94da4e4ec29a4978c920b53ce306ec333b3f7ac0216ff59637048c6997cfea4a34a87f2a0448796 SHA512 647ad13b7d45b3c5d20683ef8fe9760cb7f213e879231b6c5780bf32771adfbf7c5e5ce694c08e5681dceda63857d7d8a2d53efb60f799d3e7290cebc02ab501
DIST patchelf-0.12.tar.gz 103075 BLAKE2B 8ea71eb75bcc40e18a168c1e65856809fcceb8f68a9939e5248464d8c2e5d14d4eb1278965727417a26e70734712121d057c3da689be397f93bdb5234a11d5ba SHA512 2563a5b22b90392d5755d9a08022daf8570fa1b741becbbca92548d0a2f82f7ee21175a2c34816a4653c89c2219bf59b1440304b0fa2d49842e398ab18b9923c
DIST patchelf-0.13.tar.gz 117997 BLAKE2B 5db88c9ff9103f2e4b8e15d7dc0d677c3956a85ce5e86e371c4c32a21c3bc219990edd71a20a6b650342eff1068c0ba0976529d62d21dcc17dfc020abf7167ec SHA512 0b4cb41dc1b76d1c0f46655d8b1c56187d2bf18fa12fad9ad6e8acd321a98df372713a92c6649479498bb5939c91ce16a1032ec03afc5a2f7c92cd68882c2bd9
+DIST patchelf-0.14.3.tar.gz 123722 BLAKE2B ca9c28c88ff6a5eb37a8cb9010642f04335b74e2132987f34bc167c140dc95cd4ac7a3ed71b7287d952a0201b12148a15f3066e5c7d3d453cc18a1e97b6283ed SHA512 2f5caa6b038e630896dc0cebaf4d6f88d91f6dee7f2ffa2fc6b90d199b3a0140b7fe39ea43e582f7ac1145309a61e11fb7ce36c579ad217c48f1b189738f79c8
diff --git a/dev-util/patchelf/patchelf-0.14.3.ebuild b/dev-util/patchelf/patchelf-0.14.3.ebuild
new file mode 100644
index 000000000000..e66de9a4aec2
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.14.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}