summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-22 14:38:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-22 16:24:34 +0200
commite85c0d27917d082fa8de489b5e4e3f9b5ab7d514 (patch)
treea5b849c58018b2de483c2b7af14eb342764eb52c /dev-util/patdiff/patdiff-0.9.0.ebuild
parentdev-ml/patience_diff: initial import (diff)
downloadgentoo-e85c0d27917d082fa8de489b5e4e3f9b5ab7d514.tar.gz
gentoo-e85c0d27917d082fa8de489b5e4e3f9b5ab7d514.tar.bz2
gentoo-e85c0d27917d082fa8de489b5e4e3f9b5ab7d514.zip
dev-util/patdiff: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-util/patdiff/patdiff-0.9.0.ebuild')
-rw-r--r--dev-util/patdiff/patdiff-0.9.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/patdiff/patdiff-0.9.0.ebuild b/dev-util/patdiff/patdiff-0.9.0.ebuild
new file mode 100644
index 000000000000..2c95dc9f4545
--- /dev/null
+++ b/dev-util/patdiff/patdiff-0.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Colored patience diffs with word-level refinement"
+HOMEPAGE="https://github.com/janestreet/patdiff"
+SRC_URI="https://github.com/janestreet/patdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/core:=
+ dev-ml/core_extended:=
+ dev-ml/patience_diff:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/re2:=
+ dev-ml/sexplib:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/pcre-ocaml:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}