summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-04-24 22:45:53 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-04-24 22:46:08 +0200
commit061e5694572cc06e6a711e03de4141af87000a7a (patch)
tree6de8e104bb0d56bdad9c9168b12ac127ca61526d /dev-util/perf
parentgnome-base/nautilus: bump to 3.34.3, drop USE=packagekit (diff)
downloadgentoo-061e5694572cc06e6a711e03de4141af87000a7a.tar.gz
gentoo-061e5694572cc06e6a711e03de4141af87000a7a.tar.bz2
gentoo-061e5694572cc06e6a711e03de4141af87000a7a.zip
dev-util/perf: use LLVM_MAX_SLOT=9 (bug 718644)
Closes: https://bugs.gentoo.org/718644 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-util/perf')
-rw-r--r--dev-util/perf/perf-5.6.4.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-util/perf/perf-5.6.4.ebuild b/dev-util/perf/perf-5.6.4.ebuild
index ac50bdd49881..3f1d4e665d10 100644
--- a/dev-util/perf/perf-5.6.4.ebuild
+++ b/dev-util/perf/perf-5.6.4.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7} )
-inherit bash-completion-r1 estack eutils toolchain-funcs python-r1 linux-info
+inherit bash-completion-r1 estack eutils llvm toolchain-funcs python-r1 linux-info
MY_PV="${PV/_/-}"
MY_PV="${MY_PV/-pre/-git}"
@@ -42,8 +42,8 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="audit? ( sys-process/audit )
crypt? ( dev-libs/openssl:0= )
clang? (
- sys-devel/clang:*
- sys-devel/llvm:*
+ <sys-devel/clang-10:*
+ <sys-devel/llvm-10:*
)
demangle? ( sys-libs/binutils-libs:= )
gtk? ( x11-libs/gtk+:2 )
@@ -75,6 +75,10 @@ S="${S_K}/tools/perf"
CONFIG_CHECK="~PERF_EVENTS ~KALLSYMS"
+pkg_setup() {
+ LLVM_MAX_SLOT=9 llvm_pkg_setup
+}
+
src_unpack() {
local paths=(
tools/arch tools/build tools/include tools/lib tools/perf tools/scripts