summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-10-30 09:09:11 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-10-30 10:25:21 +0100
commite13c85b079360f3eec022026813de66aa249d5ac (patch)
tree9ff29efaf4d1f0b669c0e2133e8b5234e046988c /dev-util/perf
parentdev-util/hipcc: Fix paths (diff)
downloadgentoo-e13c85b079360f3eec022026813de66aa249d5ac.tar.gz
gentoo-e13c85b079360f3eec022026813de66aa249d5ac.tar.bz2
gentoo-e13c85b079360f3eec022026813de66aa249d5ac.zip
dev-util/perf: drop 6.3-r1, 6.4-r1
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-util/perf')
-rw-r--r--dev-util/perf/Manifest1
-rw-r--r--dev-util/perf/perf-6.3-r1.ebuild278
-rw-r--r--dev-util/perf/perf-6.4-r1.ebuild313
3 files changed, 0 insertions, 592 deletions
diff --git a/dev-util/perf/Manifest b/dev-util/perf/Manifest
index f24a9347ce54..c4f16a986c7e 100644
--- a/dev-util/perf/Manifest
+++ b/dev-util/perf/Manifest
@@ -1,3 +1,2 @@
DIST linux-6.3.tar.xz 136891752 BLAKE2B f1887c8924efa8d0cb14c4e604affd0b0168bcf20f56a37c027405c7bc11aba822a43fcb38ccb55a81a26f747d00e1ab5a6554818affbf1e1c7ef5220150fc69 SHA512 768979440f4907ba64d4481b383d6101faf208f27a0b897156123aa278c5743fe3c4f61945b2541429c532d45382aaee8899ea9d44a1d2895bfbb79bfd937f65
-DIST linux-6.4.tar.xz 137794856 BLAKE2B b59eb04a8715af9f686978812e6d4a466172bb859f80657076de14cd0828b4fac15b688ff8959f5c65485f7f6bef26590412c66821e720de843cb8666f226c90 SHA512 11a48b25e0b513782d3b89101c2ec8dd9cefd6ce08dc63a91137903b66392aa72ca1fe32816710673af84dd47de3ab8738056a6af93dc0d5e60ef4b869b49928
DIST linux-6.5.tar.xz 138898084 BLAKE2B 2e641b79a080e8f4ce283bcf6b74e2c6f15a374367f1c4c875c663868dbe801317340824fb3adb46b3a51d3b7e1f67cc4e8144d367621ec43ffba5c4eb8abb39 SHA512 1b59dc5e65d4922c3217a8c8f19022dfd6595ae89747861d825bfeb51a4ae6c85449d05db69635a712bef7b355b80318195665582d8933b1fed6ba582f6ff257
diff --git a/dev-util/perf/perf-6.3-r1.ebuild b/dev-util/perf/perf-6.3-r1.ebuild
deleted file mode 100644
index d519238f14e1..000000000000
--- a/dev-util/perf/perf-6.3-r1.ebuild
+++ /dev/null
@@ -1,278 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit bash-completion-r1 estack flag-o-matic llvm toolchain-funcs python-r1 linux-info
-
-DESCRIPTION="Userland tools for Linux Performance Counters"
-HOMEPAGE="https://perf.wiki.kernel.org/"
-
-LINUX_V="${PV:0:1}.x"
-if [[ ${PV} == *_rc* ]] ; then
- LINUX_VER=$(ver_cut 1-2).$(($(ver_cut 3)-1))
- PATCH_VERSION=$(ver_cut 1-3)
- LINUX_PATCH=patch-${PV//_/-}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/${LINUX_PATCH}
- https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [[ ${PV} == *.*.* ]] ; then
- # stable-release series
- LINUX_VER=$(ver_cut 1-2)
- LINUX_PATCH=patch-${PV}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
- SRC_URI=""
-fi
-
-LINUX_SOURCES="linux-${LINUX_VER}.tar.xz"
-SRC_URI+=" https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="audit babeltrace caps clang crypt debug +doc gtk java libpfm lzma numa perl python slang systemtap unwind zstd"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# setuptools (and Python) are always needed even if not building Python bindings
-BDEPEND="
- ${LINUX_PATCH+dev-util/patchutils}
- ${PYTHON_DEPS}
- >=app-arch/tar-1.34-r2
- dev-python/setuptools[${PYTHON_USEDEP}]
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
- doc? (
- app-text/asciidoc
- app-text/sgml-common
- app-text/xmlto
- sys-process/time
- )
-"
-
-RDEPEND="
- audit? ( sys-process/audit )
- babeltrace? ( dev-util/babeltrace )
- caps? ( sys-libs/libcap )
- clang? (
- sys-devel/clang:=
- sys-devel/llvm:=
- )
- crypt? ( dev-libs/openssl:= )
- gtk? ( x11-libs/gtk+:2 )
- java? ( virtual/jre:* )
- libpfm? ( dev-libs/libpfm:= )
- lzma? ( app-arch/xz-utils )
- numa? ( sys-process/numactl )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- slang? ( sys-libs/slang )
- systemtap? ( dev-util/systemtap )
- unwind? ( sys-libs/libunwind:= )
- zstd? ( app-arch/zstd:= )
- dev-libs/elfutils
- sys-libs/binutils-libs:=
- sys-libs/zlib
-"
-
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-5.10
- java? ( virtual/jdk )
-"
-
-S_K="${WORKDIR}/linux-${LINUX_VER}"
-S="${S_K}/tools/perf"
-
-CONFIG_CHECK="~PERF_EVENTS ~KALLSYMS"
-
-QA_FLAGS_IGNORED=(
- 'usr/bin/perf-read-vdso32' # not linked with anything except for libc
- 'usr/libexec/perf-core/dlfilters/.*' # plugins
-)
-
-pkg_pretend() {
- if ! use doc ; then
- ewarn "Without the doc USE flag you won't get any documentation nor man pages."
- ewarn "And without man pages, you won't get any --help output for perf and its"
- ewarn "sub-tools."
- fi
-}
-
-pkg_setup() {
- use clang && llvm_pkg_setup
- # We enable python unconditionally as libbpf always generates
- # API headers using python script
- python_setup
-}
-
-# src_unpack and src_prepare are copied to dev-util/bpftool since
-# it's building from the same tarball, please keep it in sync with bpftool
-src_unpack() {
- local paths=(
- tools/arch tools/build tools/include tools/lib tools/perf tools/scripts
- scripts include lib "arch/*/lib"
- )
-
- # We expect the tar implementation to support the -j option (both
- # GNU tar and libarchive's tar support that).
- echo ">>> Unpacking ${LINUX_SOURCES} (${paths[*]}) to ${PWD}"
- gtar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
- "${paths[@]/#/linux-${LINUX_VER}/}" || die
-
- if [[ -n ${LINUX_PATCH} ]] ; then
- eshopts_push -o noglob
- ebegin "Filtering partial source patch"
- filterdiff -p1 ${paths[@]/#/-i } -z "${DISTDIR}"/${LINUX_PATCH} \
- > ${P}.patch
- eend $? || die "filterdiff failed"
- eshopts_pop
- fi
-
- local a
- for a in ${A}; do
- [[ ${a} == ${LINUX_SOURCES} ]] && continue
- [[ ${a} == ${LINUX_PATCH} ]] && continue
- unpack ${a}
- done
-}
-
-src_prepare() {
- default
- if [[ -n ${LINUX_PATCH} ]] ; then
- pushd "${S_K}" >/dev/null || die
- eapply "${WORKDIR}"/${P}.patch
- popd || die
- fi
-
- pushd "${S_K}" >/dev/null || die
- eapply "${FILESDIR}"/perf-6.0-clang.patch
- eapply "${FILESDIR}"/perf-6.0-c++17.patch
- popd || die
-
- # Drop some upstream too-developer-oriented flags and fix the
- # Makefile in general
- sed -i \
- -e "s@\$(sysconfdir_SQ)/bash_completion.d@$(get_bashcompdir)@" \
- "${S}"/Makefile.perf || die
- # A few places still use -Werror w/out $(WERROR) protection.
- sed -i -e 's@-Werror@@' \
- "${S}"/Makefile.perf "${S_K}"/tools/lib/bpf/Makefile \
- "${S_K}"/tools/lib/perf/Makefile || die
-
- # Avoid the call to make kernelversion
- sed -i -e '/PERF-VERSION-GEN/d' Makefile.perf || die
- echo "#define PERF_VERSION \"${PV}\"" > PERF-VERSION-FILE
-
- # The code likes to compile local assembly files which lack ELF markings.
- find -name '*.S' -exec sed -i '$a.section .note.GNU-stack,"",%progbits' {} +
-}
-
-puse() { usex $1 "" no; }
-perf_make() {
- # The arch parsing is a bit funky. The perf tools package is integrated
- # into the kernel, so it wants an ARCH that looks like the kernel arch,
- # but it also wants to know about the split value -- i386/x86_64 vs just
- # x86. We can get that by telling the func to use an older linux version.
- # It's kind of a hack, but not that bad ...
-
- # LIBDIR sets a search path of perf-gtk.so. Bug 515954
-
- local arch=$(tc-arch-kernel)
- local java_dir
- use java && java_dir="${EPREFIX}/etc/java-config-2/current-system-vm"
- # FIXME: NO_CORESIGHT
- local emakeargs=(
- V=1 VF=1
- HOSTCC="$(tc-getBUILD_CC)" HOSTLD="$(tc-getBUILD_LD)"
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" AR="$(tc-getAR)" LD="$(tc-getLD)" NM="$(tc-getNM)"
- PKG_CONFIG="$(tc-getPKG_CONFIG)"
- prefix="${EPREFIX}/usr" bindir_relative="bin"
- tipdir="share/doc/${PF}"
- EXTRA_CFLAGS="${CFLAGS}"
- EXTRA_LDFLAGS="${LDFLAGS}"
- ARCH="${arch}"
- JDIR="${java_dir}"
- LIBCLANGLLVM=$(usex clang 1 "")
- LIBPFM4=$(usex libpfm 1 "")
- NO_AUXTRACE=""
- NO_BACKTRACE=""
- NO_CORESIGHT=1
- NO_DEMANGLE=
- GTK2=$(usex gtk 1 "")
- feature-gtk2-infobar=$(usex gtk 1 "")
- NO_JVMTI=$(puse java)
- NO_LIBAUDIT=$(puse audit)
- NO_LIBBABELTRACE=$(puse babeltrace)
- NO_LIBBIONIC=1
- NO_LIBBPF=
- NO_LIBCAP=$(puse caps)
- NO_LIBCRYPTO=$(puse crypt)
- NO_LIBDW_DWARF_UNWIND=
- NO_LIBELF=
- NO_LIBNUMA=$(puse numa)
- NO_LIBPERL=$(puse perl)
- NO_LIBPYTHON=$(puse python)
- NO_LIBUNWIND=$(puse unwind)
- NO_LIBZSTD=$(puse zstd)
- NO_SDT=$(puse systemtap)
- NO_SLANG=$(puse slang)
- NO_LZMA=$(puse lzma)
- NO_ZLIB=
- WERROR=0
- LIBDIR="/usr/libexec/perf-core"
- libdir="${EPREFIX}/usr/$(get_libdir)"
- plugindir="${EPREFIX}/usr/$(get_libdir)/perf/plugins"
- "$@"
- )
- emake "${emakeargs[@]}"
-}
-
-src_compile() {
- filter-lto
-
- # test-clang.bin not build with g++
- if use clang; then
- make -C "${S_K}/tools/build/feature" V=1 CXX=${CHOST}-clang++ test-clang.bin || die
- fi
- perf_make -f Makefile.perf
- use doc && perf_make -C Documentation man
-}
-
-src_test() {
- :
-}
-
-src_install() {
- _install_python_ext() {
- perf_make -f Makefile.perf install-python_ext DESTDIR="${D}"
- }
-
- perf_make -f Makefile.perf install DESTDIR="${D}"
-
- if use python; then
- python_foreach_impl _install_python_ext
- fi
-
- if use gtk; then
- local libdir
- libdir="$(get_libdir)"
- # on some arches it ends up in lib even on 64bit, ppc64 for instance.
- [[ -f "${ED}"/usr/lib/libperf-gtk.so ]] && libdir="lib"
- mv "${ED}"/usr/${libdir}/libperf-gtk.so \
- "${ED}"/usr/libexec/perf-core || die
- fi
-
- dodoc CREDITS
-
- dodoc *txt Documentation/*.txt
-
- # perf needs this decompressed to print out tips for users
- docompress -x /usr/share/doc/${PF}/tips.txt
-
- if use doc ; then
- doman Documentation/*.1
- fi
-}
diff --git a/dev-util/perf/perf-6.4-r1.ebuild b/dev-util/perf/perf-6.4-r1.ebuild
deleted file mode 100644
index a1a140af0ed7..000000000000
--- a/dev-util/perf/perf-6.4-r1.ebuild
+++ /dev/null
@@ -1,313 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit bash-completion-r1 estack flag-o-matic linux-info llvm toolchain-funcs python-r1
-
-DESCRIPTION="Userland tools for Linux Performance Counters"
-HOMEPAGE="https://perf.wiki.kernel.org/"
-
-LINUX_V="${PV:0:1}.x"
-if [[ ${PV} == *_rc* ]] ; then
- LINUX_VER=$(ver_cut 1-2).$(($(ver_cut 3)-1))
- PATCH_VERSION=$(ver_cut 1-3)
- LINUX_PATCH=patch-${PV//_/-}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/${LINUX_PATCH}
- https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [[ ${PV} == *.*.* ]] ; then
- # stable-release series
- LINUX_VER=$(ver_cut 1-2)
- LINUX_PATCH=patch-${PV}.xz
- SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
- SRC_URI=""
-fi
-
-LINUX_SOURCES="linux-${LINUX_VER}.tar.xz"
-SRC_URI+=" https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="audit babeltrace bpf caps clang crypt debug +doc gtk java libpfm libtraceevent libtracefs lzma numa perl python slang systemtap tcmalloc unwind zstd"
-
-REQUIRED_USE="
- bpf? ( clang )
- ${PYTHON_REQUIRED_USE}
-"
-
-# setuptools (and Python) are always needed even if not building Python bindings
-BDEPEND="
- ${LINUX_PATCH+dev-util/patchutils}
- ${PYTHON_DEPS}
- >=app-arch/tar-1.34-r2
- dev-python/setuptools[${PYTHON_USEDEP}]
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
- doc? (
- app-text/asciidoc
- app-text/sgml-common
- app-text/xmlto
- sys-process/time
- )
-"
-
-RDEPEND="
- audit? ( sys-process/audit )
- babeltrace? ( dev-util/babeltrace )
- bpf? (
- dev-libs/libbpf
- dev-util/bpftool
- dev-util/pahole
- )
- caps? ( sys-libs/libcap )
- clang? (
- sys-devel/clang:=
- sys-devel/llvm:=
- )
- crypt? ( dev-libs/openssl:= )
- gtk? ( x11-libs/gtk+:2 )
- java? ( virtual/jre:* )
- libpfm? ( dev-libs/libpfm:= )
- libtraceevent? ( dev-libs/libtraceevent )
- libtracefs? ( dev-libs/libtracefs )
- lzma? ( app-arch/xz-utils )
- numa? ( sys-process/numactl )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- slang? ( sys-libs/slang )
- systemtap? ( dev-util/systemtap )
- tcmalloc? ( dev-util/google-perftools )
- unwind? ( sys-libs/libunwind:= )
- zstd? ( app-arch/zstd:= )
- dev-libs/elfutils
- sys-libs/binutils-libs:=
- sys-libs/zlib
-"
-
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-5.10
- java? ( virtual/jdk )
-"
-
-S_K="${WORKDIR}/linux-${LINUX_VER}"
-S="${S_K}/tools/perf"
-
-CONFIG_CHECK="
- ~DEBUG_INFO
- ~FTRACE
- ~FTRACE_SYSCALLS
- ~FUNCTION_TRACER
- ~KALLSYMS
- ~KALLSYMS_ALL
- ~KPROBES
- ~KPROBE_EVENTS
- ~PERF_EVENTS
- ~UPROBES
- ~UPROBE_EVENTS
-"
-
-QA_FLAGS_IGNORED=(
- 'usr/bin/perf-read-vdso32' # not linked with anything except for libc
- 'usr/libexec/perf-core/dlfilters/.*' # plugins
-)
-
-pkg_pretend() {
- if ! use doc ; then
- ewarn "Without the doc USE flag you won't get any documentation nor man pages."
- ewarn "And without man pages, you won't get any --help output for perf and its"
- ewarn "sub-tools."
- fi
-}
-
-pkg_setup() {
- use clang && llvm_pkg_setup
- # We enable python unconditionally as libbpf always generates
- # API headers using python script
- python_setup
-
- if use bpf ; then
- CONFIG_CHECK+="~BPF ~BPF_EVENTS ~BPF_SYSCALL ~DEBUG_INFO_BTF ~HAVE_EBPF_JIT"
- fi
-
- linux-info_pkg_setup
-}
-
-# src_unpack and src_prepare are copied to dev-util/bpftool since
-# it's building from the same tarball, please keep it in sync with bpftool
-src_unpack() {
- local paths=(
- kernel/bpf tools/{arch,bpf,build,include,lib,perf,scripts}
- scripts include lib "arch/*/lib"
- )
-
- # We expect the tar implementation to support the -j option (both
- # GNU tar and libarchive's tar support that).
- echo ">>> Unpacking ${LINUX_SOURCES} (${paths[*]}) to ${PWD}"
- gtar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
- "${paths[@]/#/linux-${LINUX_VER}/}" || die
-
- if [[ -n ${LINUX_PATCH} ]] ; then
- eshopts_push -o noglob
- ebegin "Filtering partial source patch"
- filterdiff -p1 ${paths[@]/#/-i } -z "${DISTDIR}"/${LINUX_PATCH} \
- > ${P}.patch
- eend $? || die "filterdiff failed"
- eshopts_pop
- fi
-
- local a
- for a in ${A}; do
- [[ ${a} == ${LINUX_SOURCES} ]] && continue
- [[ ${a} == ${LINUX_PATCH} ]] && continue
- unpack ${a}
- done
-}
-
-src_prepare() {
- default
- if [[ -n ${LINUX_PATCH} ]] ; then
- pushd "${S_K}" >/dev/null || die
- eapply "${WORKDIR}"/${P}.patch
- popd || die
- fi
-
- pushd "${S_K}" >/dev/null || die
- eapply "${FILESDIR}"/perf-6.0-clang.patch
- eapply "${FILESDIR}"/perf-6.0-c++17.patch
- eapply "${FILESDIR}"/perf-6.4-libtracefs.patch
- popd || die
-
- # Drop some upstream too-developer-oriented flags and fix the
- # Makefile in general
- sed -i \
- -e "s@\$(sysconfdir_SQ)/bash_completion.d@$(get_bashcompdir)@" \
- "${S}"/Makefile.perf || die
- # A few places still use -Werror w/out $(WERROR) protection.
- sed -i -e 's@-Werror@@' \
- "${S}"/Makefile.perf "${S_K}"/tools/lib/bpf/Makefile \
- "${S_K}"/tools/lib/perf/Makefile || die
-
- # Avoid the call to make kernelversion
- sed -i -e '/PERF-VERSION-GEN/d' Makefile.perf || die
- echo "#define PERF_VERSION \"${PV}\"" > PERF-VERSION-FILE
-
- # The code likes to compile local assembly files which lack ELF markings.
- find -name '*.S' -exec sed -i '$a.section .note.GNU-stack,"",%progbits' {} +
-}
-
-puse() { usex $1 "" 1; }
-perf_make() {
- # The arch parsing is a bit funky. The perf tools package is integrated
- # into the kernel, so it wants an ARCH that looks like the kernel arch,
- # but it also wants to know about the split value -- i386/x86_64 vs just
- # x86. We can get that by telling the func to use an older linux version.
- # It's kind of a hack, but not that bad ...
-
- # LIBDIR sets a search path of perf-gtk.so. Bug 515954
-
- local arch=$(tc-arch-kernel)
- local java_dir
- use java && java_dir="${EPREFIX}/etc/java-config-2/current-system-vm"
- # FIXME: NO_CORESIGHT
- local emakeargs=(
- V=1 VF=1
- HOSTCC="$(tc-getBUILD_CC)" HOSTLD="$(tc-getBUILD_LD)"
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" AR="$(tc-getAR)" LD="$(tc-getLD)" NM="$(tc-getNM)"
- PKG_CONFIG="$(tc-getPKG_CONFIG)"
- prefix="${EPREFIX}/usr" bindir_relative="bin"
- tipdir="share/doc/${PF}"
- EXTRA_CFLAGS="${CFLAGS}"
- EXTRA_LDFLAGS="${LDFLAGS}"
- ARCH="${arch}"
- BUILD_BPF_SKEL=$(usex bpf 1 "") \
- BUILD_NONDISTRO=1
- JDIR="${java_dir}"
- CORESIGHT=
- GTK2=$(usex gtk 1 "")
- LIBCLANGLLVM=$(usex clang 1 "")
- feature-gtk2-infobar=$(usex gtk 1 "")
- NO_AUXTRACE=
- NO_BACKTRACE=
- NO_DEMANGLE=
- NO_JEVENTS=$(puse python)
- NO_JVMTI=$(puse java)
- NO_LIBAUDIT=$(puse audit)
- NO_LIBBABELTRACE=$(puse babeltrace)
- NO_LIBBIONIC=1
- NO_LIBBPF=$(puse bpf)
- NO_LIBCAP=$(puse caps)
- NO_LIBCRYPTO=$(puse crypt)
- NO_LIBDW_DWARF_UNWIND=
- NO_LIBELF=
- NO_LIBNUMA=$(puse numa)
- NO_LIBPERL=$(puse perl)
- NO_LIBPFM4=$(puse libpfm)
- NO_LIBPYTHON=$(puse python)
- NO_LIBTRACEEVENT=$(puse libtraceevent)
- NO_LIBUNWIND=$(puse unwind)
- NO_LIBZSTD=$(puse zstd)
- NO_SDT=$(puse systemtap)
- NO_SLANG=$(puse slang)
- NO_LZMA=$(puse lzma)
- NO_ZLIB=
- TCMALLOC=$(usex tcmalloc 1 "")
- WERROR=0
- LIBDIR="/usr/libexec/perf-core"
- libdir="${EPREFIX}/usr/$(get_libdir)"
- plugindir="${EPREFIX}/usr/$(get_libdir)/perf/plugins"
- "$@"
- )
- emake "${emakeargs[@]}"
-}
-
-src_compile() {
- filter-lto
-
- # test-clang.bin not build with g++
- if use clang; then
- make -C "${S_K}/tools/build/feature" V=1 CXX=${CHOST}-clang++ test-clang.bin || die
- fi
- perf_make -f Makefile.perf
- use doc && perf_make -C Documentation man
-}
-
-src_test() {
- :
-}
-
-src_install() {
- _install_python_ext() {
- perf_make -f Makefile.perf install-python_ext DESTDIR="${D}"
- }
-
- perf_make -f Makefile.perf install DESTDIR="${D}"
-
- if use python; then
- python_foreach_impl _install_python_ext
- fi
-
- if use gtk; then
- local libdir
- libdir="$(get_libdir)"
- # on some arches it ends up in lib even on 64bit, ppc64 for instance.
- [[ -f "${ED}"/usr/lib/libperf-gtk.so ]] && libdir="lib"
- mv "${ED}"/usr/${libdir}/libperf-gtk.so \
- "${ED}"/usr/libexec/perf-core || die
- fi
-
- dodoc CREDITS
-
- dodoc *txt Documentation/*.txt
-
- # perf needs this decompressed to print out tips for users
- docompress -x /usr/share/doc/${PF}/tips.txt
-
- if use doc ; then
- doman Documentation/*.1
- fi
-}