summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/pida
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/pida')
-rw-r--r--dev-util/pida/Manifest1
-rw-r--r--dev-util/pida/files/pida-0.6.1-fix_implicit_declaration.patch10
-rw-r--r--dev-util/pida/metadata.xml8
-rw-r--r--dev-util/pida/pida-0.6.2-r1.ebuild45
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/pida/Manifest b/dev-util/pida/Manifest
new file mode 100644
index 000000000000..3bb88bcad1bb
--- /dev/null
+++ b/dev-util/pida/Manifest
@@ -0,0 +1 @@
+DIST pida-0.6.2.tar.gz 812069 SHA256 f8476c9a36399b525a18761b709c204ae3f3c4344a4334b726d4ddccfca17a34 SHA512 7793bda11f890d329e0748e789f41c8907fb47c6d4e40f9f2a6ae6d098e606cbf29aae0946786e47b5fac45a672f84c78925cdcf2b8fd7ad05d758630c3b8ea3 WHIRLPOOL 9a11770a0c09c58a17e163f4f4ef8924e9481a95de85f844586b759dbe8c50f4ed32f26beeabd2a53d1f10ac0b459fd715727f9c4b6d0c8f6046a9b9568ee91b
diff --git a/dev-util/pida/files/pida-0.6.1-fix_implicit_declaration.patch b/dev-util/pida/files/pida-0.6.1-fix_implicit_declaration.patch
new file mode 100644
index 000000000000..0636a0dd7279
--- /dev/null
+++ b/dev-util/pida/files/pida-0.6.1-fix_implicit_declaration.patch
@@ -0,0 +1,10 @@
+--- contrib/moo/moo.override
++++ contrib/moo/moo.override
+@@ -6,6 +6,7 @@
+ #include <pygobject.h>
+ #include <pygtk/pygtk.h>
+ #include "moobigpaned.h"
++#include "moopython-utils.h"
+ %%
+ modulename moo_stub
+ %%
diff --git a/dev-util/pida/metadata.xml b/dev-util/pida/metadata.xml
new file mode 100644
index 000000000000..42c241eb0463
--- /dev/null
+++ b/dev-util/pida/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pida</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/pida/pida-0.6.2-r1.ebuild b/dev-util/pida/pida-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..4b440c3327b8
--- /dev/null
+++ b/dev-util/pida/pida-0.6.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+# json module required.
+
+DESCRIPTION="Gtk and/or Vim-based Python Integrated Development Application"
+HOMEPAGE="http://pida.co.uk/ http://pypi.python.org/pypi/pida"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=app-editors/gvim-6.3[gtk,${PYTHON_USEDEP}]
+ >=dev-python/anyvc-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/bpython-0.9.7[gtk,${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
+ >dev-python/pygtkhelpers-0.4.1[${PYTHON_USEDEP}]
+ >=x11-libs/vte-0.11.11-r2:0[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Don't require argparse with Python 2.7.
+ sed -e "/argparse/d" -i setup.py || die "sed failed"
+
+ epatch "${FILESDIR}/${PN}-0.6.1-fix_implicit_declaration.patch"
+ emake -C contrib/moo moo-pygtk.c
+}
+
+src_install() {
+ distutils-r1_src_install
+ make_desktop_entry pida Pida Development
+}