summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-02-09 13:55:29 -0700
committerTim Harder <radhermit@gentoo.org>2020-02-09 13:56:05 -0700
commit0664508f2c985dc9e68714f4d7e41d473a152b00 (patch)
tree1911a003f6975e8df2e81842feb9f53d4f14f604 /dev-util/pkgcheck
parentdev-python/snakeoil: remove old (diff)
downloadgentoo-0664508f2c985dc9e68714f4d7e41d473a152b00.tar.gz
gentoo-0664508f2c985dc9e68714f4d7e41d473a152b00.tar.bz2
gentoo-0664508f2c985dc9e68714f4d7e41d473a152b00.zip
dev-util/pkgcheck: version bump to 0.7.6
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-util/pkgcheck')
-rw-r--r--dev-util/pkgcheck/Manifest1
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.7.6.ebuild54
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild2
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-util/pkgcheck/Manifest b/dev-util/pkgcheck/Manifest
index 10ae4e49fe31..e176b6d60a29 100644
--- a/dev-util/pkgcheck/Manifest
+++ b/dev-util/pkgcheck/Manifest
@@ -1,2 +1,3 @@
DIST pkgcheck-0.7.4.tar.gz 222384 BLAKE2B 4461a4b01755a6e1095c4a80c001381807e7b153ecc1b7770b0b58e2f4aebc2db35cbe4f37354424ecb8c7d139cc2258568df28c00f0a0c082dec8831161c885 SHA512 11ba1ea9e40d56fb24c136296b8ff06643d3519e330421fd0ec336ff5d9fb079f9e04269cb1521a60e6d68fa5cd7c03e0c595a042d7f9ec77944a30e399abe74
DIST pkgcheck-0.7.5.tar.gz 229979 BLAKE2B 134a67e139fed22f70fc5af5a1644df17ac46ca093b47cae0d362702ff33be320b838ac7c3c6e6d3c309644f7399ff0c33d6e6152d385be8312311b760d636d8 SHA512 eb46847ad5293e5cd6043e5f1edbb4307bf41593bc19a44c73ccb67590545055ce9fd3cddc25e4cc693bb2666aaf24944070796546743e0d7417f8e47cd516d0
+DIST pkgcheck-0.7.6.tar.gz 234637 BLAKE2B 31c31d987aed03e4a61f58a3dc3074985a4f436e3598f11257d602a668525f24e45c540d56e5779237cd36299b0ab73b9a59e3482099cb5accbb3ea8437cd7c5 SHA512 cfded3a5a0249ee9279fe93156ef524cafe7302915dfbbb01acd0bdc3acefcd1e90c6bcfbf3dc40bd5cb71680cc6453b1de045878d75a9ade00c432e663fd136
diff --git a/dev-util/pkgcheck/pkgcheck-0.7.6.ebuild b/dev-util/pkgcheck/pkgcheck-0.7.6.ebuild
new file mode 100644
index 000000000000..d3aed7fc337b
--- /dev/null
+++ b/dev-util/pkgcheck/pkgcheck-0.7.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="pkgcore-based QA utility for ebuild repos"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="network perl test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="
+ ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
+ ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND="
+ >=dev-python/snakeoil-0.8.8[${PYTHON_USEDEP}]
+ >=sys-apps/pkgcore-0.10.11[${PYTHON_USEDEP}]"
+fi
+RDEPEND+="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pathspec[${PYTHON_USEDEP}]
+ network? ( dev-python/requests[${PYTHON_USEDEP}] )
+ perl? ( dev-perl/Gentoo-PerlMod-Version )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index 61ffc645f69f..d3aed7fc337b 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -28,7 +28,7 @@ if [[ ${PV} == *9999 ]]; then
~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
else
RDEPEND="
- >=dev-python/snakeoil-0.8.7[${PYTHON_USEDEP}]
+ >=dev-python/snakeoil-0.8.8[${PYTHON_USEDEP}]
>=sys-apps/pkgcore-0.10.11[${PYTHON_USEDEP}]"
fi
RDEPEND+="