summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-03-28 15:55:00 -0400
committerMike Gilbert <floppym@gentoo.org>2018-03-28 15:55:19 -0400
commit594f5ad6d2bd904ba3cb1fd061bdf41ab72341b0 (patch)
treebb82ffe7f48b5de48900cf971c6e08d91013bd7b /dev-util/pkgconf
parentdev-python/google-apputils: stable 0.4.2-r2 for hppa, bug #621620 (diff)
downloadgentoo-594f5ad6d2bd904ba3cb1fd061bdf41ab72341b0.tar.gz
gentoo-594f5ad6d2bd904ba3cb1fd061bdf41ab72341b0.tar.bz2
gentoo-594f5ad6d2bd904ba3cb1fd061bdf41ab72341b0.zip
dev-util/pkgconf: bump to 1.4.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6_p81
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/metadata.xml3
-rw-r--r--dev-util/pkgconf/pkgconf-1.4.2.ebuild72
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild4
4 files changed, 78 insertions, 2 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index 7eae2b53ae50..3aee28f3f18b 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1,3 +1,4 @@
DIST pkgconf-1.3.10.tar.xz 272704 BLAKE2B 7d39a17ba100818eecb64acc46d7000a5d7ecb2493d7d9b75a7f2451ac3499bb5de68a38cca2188b19937410b3a82bc8a910a8b7cec211315980c0d9c49f8c81 SHA512 22ccc6b41b4571992f00e0b2e6f9922fd7f1bf9ef1b790ff978d8bff8ca0697321f7a7ecf1a193ccb4efda2c5d6430c1ad24487a50d3ab27f9f16e6be9fb9e83
DIST pkgconf-1.3.7.tar.xz 271840 BLAKE2B f4bb44e92ef2903a5962c85e0d4a939adf035c5e92fbd1d8a50d4022507d1f442e459849b537cc2b648c7a1bb5eac33aabf8a46d8b0df8794514596adee9888d SHA512 6c06afc4fe64c94a833db98d4dc7881192d38cc28eb1fb86345f4ce065489930ac953aa9f6b2df172127244cb1cbab1c85a042aa0f6be4fa18bf9dcd83173960
DIST pkgconf-1.3.90.tar.xz 285036 BLAKE2B e56e3ea3a6552ff190f239bf4d8d7e3d63c0ecc6a771d0a7c33aeacf6da61190abfed1ac2268d28d64efc298bc4b2b3f032eeaf8b2be628bef1d12de4b1aec36 SHA512 8efca947546969fea63e97f23eb1b5af49a1f2378eec66ff4f403fa218bcb3d5fed62a32fd6be70d9ebf39c8024bb9714cd0c2a52e6960c98021cabefc274530
+DIST pkgconf-1.4.2.tar.xz 285548 BLAKE2B ad48bac309e90f2c2958ee19ebbf95ec90c55ebd98a44486f47cc403b8c193131377433a23f16adb64bf97832ff5a0c20e0a3d01da5c6adb2b70483dcf23b9cf SHA512 d9d3bfc7ddc3ceda65f7ad11b1a3c8a48aee0b5ac135aeb54b41091ca1ef0d9a5cda4a5c1ba2470ec12ce870a361eeddd802243eda3c2e2c0f2be3e7fe0ca236
diff --git a/dev-util/pkgconf/metadata.xml b/dev-util/pkgconf/metadata.xml
index 6707db3556f0..f6730b8bcc6e 100644
--- a/dev-util/pkgconf/metadata.xml
+++ b/dev-util/pkgconf/metadata.xml
@@ -5,6 +5,9 @@
<email>floppym@gentoo.org</email>
<name>Mike Gilbert</name>
</maintainer>
+ <slots>
+ <subslots>SONAME version of libpkgconf</subslots>
+ </slots>
<use>
<flag name="pkg-config">Install as a replacement for dev-util/pkgconfig</flag>
</use>
diff --git a/dev-util/pkgconf/pkgconf-1.4.2.ebuild b/dev-util/pkgconf/pkgconf-1.4.2.ebuild
new file mode 100644
index 000000000000..e2b768e8e572
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-1.4.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit multilib-minimal
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0/3"
+IUSE="+pkg-config test"
+
+# tests require 'kyua'
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+RDEPEND="
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+)
+
+src_prepare() {
+ default
+
+ [[ ${PV} == "9999" ]] && eautoreconf
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config
+ )
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf
+}
+
+multilib_src_install() {
+ default
+
+ if use pkg-config; then
+ dosym pkgconf /usr/bin/pkg-config
+ else
+ rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index 86434bc5ebfd..e2b768e8e572 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,7 +17,7 @@ DESCRIPTION="pkg-config compatible replacement with no dependencies other than A
HOMEPAGE="https://github.com/pkgconf/pkgconf"
LICENSE="BSD-1"
-SLOT="0"
+SLOT="0/3"
IUSE="+pkg-config test"
# tests require 'kyua'