summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-04-09 20:03:39 -0700
committerZac Medico <zmedico@gentoo.org>2016-04-09 20:03:39 -0700
commitde8f6e9c73908ed496c6cde5041374cfe9f76dde (patch)
tree9026ad2c9e7f3b821c45abe564773d06998e2627 /dev-util/ply/ply-0_pre20160313.ebuild
parentapp-arch/p7zip: bup for bug 579196 (diff)
downloadgentoo-de8f6e9c73908ed496c6cde5041374cfe9f76dde.tar.gz
gentoo-de8f6e9c73908ed496c6cde5041374cfe9f76dde.tar.bz2
gentoo-de8f6e9c73908ed496c6cde5041374cfe9f76dde.zip
dev-util/ply: new package
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/ply/ply-0_pre20160313.ebuild')
-rw-r--r--dev-util/ply/ply-0_pre20160313.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/ply/ply-0_pre20160313.ebuild b/dev-util/ply/ply-0_pre20160313.ebuild
new file mode 100644
index 000000000000..8112b400542c
--- /dev/null
+++ b/dev-util/ply/ply-0_pre20160313.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools linux-info
+
+DESCRIPTION="Dynamic instrumentation of the Linux kernel with BPF and kprobes"
+HOMEPAGE="https://github.com/iovisor/ply"
+EGIT_COMMIT="cfc56c789ad1eff1080ecb0dad18d009b91ae8ea"
+SRC_URI="https://github.com/iovisor/ply/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+pkg_pretend() {
+ local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
+ ~BPF_JIT ~HAVE_BPF_JIT ~BPF_EVENTS"
+
+ check_extra_config
+}
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+ default
+}
+
+src_configure() {
+ local econf_args=() kerneldir_orig
+ if [[ -d ${KERNEL_DIR} ]]; then
+ # Using KBUILD_OUTPUT can fail, depending on the source tree
+ # state (it might demand that we make mrproper). Therefore,
+ # create a symlink copy of the source tree so that we are free
+ # to clean things up as needed.
+ kerneldir_orig=${KERNEL_DIR}
+ cp -sR "${kerneldir_orig}" "${T}/kerneldir" || die
+ export KERNEL_DIR="${T}/kerneldir"
+ pushd "${KERNEL_DIR}" || die
+ # avoid sandbox violation for scripts/kconfig/.conf.cmd
+ find . -name '\.*' -delete
+ cp "${kerneldir_orig}/.config" ./.config || die
+ set_arch_to_kernel
+ make mrproper oldconfig prepare || die
+ popd || die
+ econf_args+=(--with-kerneldir="${KERNEL_DIR}")
+ fi
+ econf "${econf_args[@]}"
+}
+
+src_install() {
+ default
+ rm -f "${ED}/usr/share/doc/${P}/COPYING"
+}