summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-08 19:44:54 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-03-08 19:44:54 +0100
commit780500a1b45f914e8722c0f4bf2e61220d3323f8 (patch)
tree8f3f730e6cfe9d0e44f2939202eda8793d7ee213 /dev-util/promu
parentapp-text/docbook-xml-simple-dtd: Tested on ~amd64-fbsd (diff)
downloadgentoo-780500a1b45f914e8722c0f4bf2e61220d3323f8.tar.gz
gentoo-780500a1b45f914e8722c0f4bf2e61220d3323f8.tar.bz2
gentoo-780500a1b45f914e8722c0f4bf2e61220d3323f8.zip
dev-util/promu: Add new snapshot
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/promu')
-rw-r--r--dev-util/promu/Manifest1
-rw-r--r--dev-util/promu/promu-0.1.0_p20180227.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/promu/Manifest b/dev-util/promu/Manifest
index b749f3e113b2..f8179f31e397 100644
--- a/dev-util/promu/Manifest
+++ b/dev-util/promu/Manifest
@@ -1 +1,2 @@
DIST promu-0.1.0.tar.gz 1065003 BLAKE2B f56dfda69dae632b1946182b1a92c059cac52867c677d415c2f321f95800d3902f8f0fbd4d4b670870f3dce34603b0c1a50df9311be70404f27e9f5afbaf4699 SHA512 18ad54b1ec9fe8975a0048b5c85609858cd500a2d3aa34e51e5c2c3d07a0df4337bac9648562e2007d5c8572e07c814c6bba7522b94836c258cde457df5815e2
+DIST promu-0.1.0_p20180227.tar.gz 1068386 BLAKE2B b850c1dfa51f86099bd7e32c131ef99a05d4f4caab441a945fddc9a2895e72b74ed3456f18ab69493fc2283902c570e78f99ea303f32998416fdfbf91c3d0cd8 SHA512 6fbe5fe92602437aee90a442028cd846d9d72179b32e601b6167420dab0a3aed22cd9d1c527320ca54a3cfce7b79167753ad9cbeb000762e845056c692212a74
diff --git a/dev-util/promu/promu-0.1.0_p20180227.ebuild b/dev-util/promu/promu-0.1.0_p20180227.ebuild
new file mode 100644
index 000000000000..94c084e7161a
--- /dev/null
+++ b/dev-util/promu/promu-0.1.0_p20180227.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/promu"
+EGIT_COMMIT="5a3cc08574c63bb853a21c570d719a0fb548dae0"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ LDFLAGS="-X github.com/prometheus/vendor/github.com/prometheus/common/version.Version=$(cat src/${EGO_PN}/VERSION)
+ -X github.com/prometheus/vendor/github.com/prometheus/common/version.Revision=${EGIT_COMMIT:0:7}
+ -extldflags \"-static\""
+ GOPATH="${S}" go build -ldflags "${LDFLAGS}" -o bin/promu src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{doc,{README,CONTRIBUTING}.md}
+}