summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-08-31 22:55:51 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-08-31 22:55:51 +0200
commitcceac36e48dd03b9494a54a95544ef083fdaee24 (patch)
tree7252361710ba59460e338b187883ab79d725e6a6 /dev-util/pycharm-community
parentmedia-sound/kwave: remove old (diff)
downloadgentoo-cceac36e48dd03b9494a54a95544ef083fdaee24.tar.gz
gentoo-cceac36e48dd03b9494a54a95544ef083fdaee24.tar.bz2
gentoo-cceac36e48dd03b9494a54a95544ef083fdaee24.zip
dev-util/pycharm-community: Version bump to 2016.2.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/pycharm-community')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2016.2.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index 9aef69b93b02..fb0f041c4529 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1,3 +1,4 @@
DIST pycharm-community-2016.1.3.tar.gz 207707566 SHA256 98c406abf20cbe18565dfe17a62ac7dba094ed15100aab566ff343eb726647cf SHA512 09327867d231b311616d76d860e27ed0c1ac20ca86eda0be9d58666993b860f3c562fa5ce7e533f898eccf7ad2c72954681c83095310bfe01c428a64c59a475e WHIRLPOOL eb03ad07a14707d0650b9991e0494e299336bb61722b6384fa1a2721cc8b692a031ac84f4cfdbd909a45bbacc6d2e1e3d6eec0e5c202a22133f953a402b38b6d
DIST pycharm-community-2016.1.4.tar.gz 207346180 SHA256 bc548a200022111e741604e76b579e71e5a75d23c2bbb9c4cb9ed88b18a3d622 SHA512 f86726d921baec5a5f2691f7e9ee4f81d4abd3a55edc09f091593434d79a51e0058025eb52f1ca5455844d47d325e209f73d7e701d218db57bcf9502244201d6 WHIRLPOOL 9e51cb7f5c2e3530666831803c4bc0dfe8d36b58da0e593763028e9097f95e778098923f837a771c063fa1336cf3a58ba4ebe14cddbbec6f9c74921a1deedb9c
DIST pycharm-community-2016.2.1.tar.gz 212670595 SHA256 76a5d58a6ecbafa48abde9823948f0614472ecbc0535c639ceb593569a1e06a7 SHA512 46777642ca0adb6aa40828d37328846b399b44c6625065ed00a6d2d46b3c82f10f1640a4206d703be84c3429ec2d76a71dfdb38fe9ae70a8b094d518d0f3a60b WHIRLPOOL 086aa3c1e05d0c0ba7fddb904a3e793dfcf00a9bd830fdd65b3bdf70b8ad9cb700fead63be7186a90b5a32a9b3584afa89a9a84c098d24dedc82daedca49ea9b
+DIST pycharm-community-2016.2.2.tar.gz 212722955 SHA256 6bf50910355f680983246ab51f7a082ae6f34f799db222986c1c59003bf1dbec SHA512 20840a8e1642ea47909bc0913a701b103843e78b29b3d0333d150d30b6ba202dc07db086795224557788b171da3265e849e01bfcb064021ad0ef78a18c67228a WHIRLPOOL ef5d3bb7a4e8069bb5eb256c84a0150773ccf87ff7a8db5ccaba58307c1ae723f17feee461e921ecc1fdc5b3682ec713880fd1a3da664308475b2cb7a2c80c88
diff --git a/dev-util/pycharm-community/pycharm-community-2016.2.2.ebuild b/dev-util/pycharm-community/pycharm-community-2016.2.2.ebuild
new file mode 100644
index 000000000000..233c50990d3d
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2016.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="/opt/${PN}/bin/fsnotifier
+ /opt/${PN}/bin/fsnotifier64"
+
+MY_PN=${PN/-community/}
+
+QA_PREBUILT="*"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_create_doc
+}