summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2021-07-10 22:58:13 +0200
committerDavide Pesavento <pesa@gentoo.org>2021-07-10 23:00:37 +0200
commit42bbd1ff5eeb2a4dc46b271571e14c48fdc9397c (patch)
treef5f46152932b0c87bbd694e81cd14a9f1e7540d1 /dev-util/qbs
parentsys-fs/mtools: Removed old (diff)
downloadgentoo-42bbd1ff5eeb2a4dc46b271571e14c48fdc9397c.tar.gz
gentoo-42bbd1ff5eeb2a4dc46b271571e14c48fdc9397c.tar.bz2
gentoo-42bbd1ff5eeb2a4dc46b271571e14c48fdc9397c.zip
dev-util/qbs: add 1.19.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-util/qbs')
-rw-r--r--dev-util/qbs/Manifest1
-rw-r--r--dev-util/qbs/metadata.xml12
-rw-r--r--dev-util/qbs/qbs-1.19.1.ebuild120
3 files changed, 129 insertions, 4 deletions
diff --git a/dev-util/qbs/Manifest b/dev-util/qbs/Manifest
index 142b017fb2d7..5243f5419bd0 100644
--- a/dev-util/qbs/Manifest
+++ b/dev-util/qbs/Manifest
@@ -1,2 +1,3 @@
DIST qbs-src-1.16.0.tar.gz 4571788 BLAKE2B 4fb06314d0d0a532574e0d245ea85b6d596850ffe4b81b621406d1bc99e0529fc491bf5c7db514d90026c0bf4916f9fa102457aab2bbaaddbbe2e90c03aa04a4 SHA512 65c5398ffad54e10e251bed79a5b58abd722c0f95a031c536fc8647d915dd696923401c767a7a8ac029f4f571b6bbf96ef4b7493bb30768f675477bd68fcc21c
DIST qbs-src-1.18.0.tar.gz 4921432 BLAKE2B 4c081434596c58d433e52ca9e335e3b4d62b75e401290895719b7fbe4f3c20cf8b34ab0753ae79a34b4e29c8859751a6276da8d6dbd5f3c711581af16ab61415 SHA512 bdef30200c7e74749c363b1d68232fd90d1dfc998722bee0e058ffcaff8e003599e0404b49f86cbeae098d59ccb5663316db5094d77b50a217fcf4ab5ae64d83
+DIST qbs-src-1.19.1.tar.gz 4961984 BLAKE2B 2b9333ac8bba12f311ad47b1315d0a61ddf3b3a804888369f3fd868fbebca4ad13bd857451cb3fe3515fd9f9e69b42b84484289e79d3e7911c69720d7d08ab29 SHA512 b53dae9631c9d4ec1f799395948a67ce4b62ae88908cce3b00f42fb0213d80d32127c3429b95d5c32c9f7c1b861fc5a52ac6952046a6d91d035539d7412a5c4d
diff --git a/dev-util/qbs/metadata.xml b/dev-util/qbs/metadata.xml
index 4311f5d8ba92..06efa80b24ba 100644
--- a/dev-util/qbs/metadata.xml
+++ b/dev-util/qbs/metadata.xml
@@ -14,10 +14,14 @@
projects across multiple platforms. Qbs can be used for any software
project, regardless of programming language, toolkit, or libraries used.
- Qbs is an all-in-one tool that generates a build graph from a
- high-level project description (like qmake or cmake) and additionally
- undertakes the task of executing the commands in the low-level build
- graph (like make).
+ Qbs projects are specified in a QML dialect. QML is a concise, easy to
+ learn, and intuitive language that is used successfully in the Qt project.
+ Its core is declarative, but it can be extended with JavaScript snippets
+ for extra flexibility.
+
+ Qbs is an all-in-one tool that generates a build graph from a high-level
+ project description (like qmake or CMake) and additionally undertakes the
+ task of executing the commands in the low-level build graph (like make).
</longdescription>
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
diff --git a/dev-util/qbs/qbs-1.19.1.ebuild b/dev-util/qbs/qbs-1.19.1.ebuild
new file mode 100644
index 000000000000..3339bb574287
--- /dev/null
+++ b/dev-util/qbs/qbs-1.19.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils toolchain-funcs
+
+MY_P=${PN}-src-${PV}
+
+DESCRIPTION="Modern build tool for software projects"
+HOMEPAGE="https://doc.qt.io/qbs/"
+SRC_URI="https://download.qt.io/official_releases/${PN}/${PV}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc examples gui test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5=
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtxml:5
+ gui? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/linguist-tools:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qttest:5
+ )
+"
+BDEPEND="
+ dev-qt/qtcore:5
+ doc? (
+ dev-qt/qdoc:5
+ dev-qt/qthelp:5
+ )
+"
+
+src_prepare() {
+ default
+
+ if ! use examples; then
+ sed -i -e '/INSTALLS +=/ s:examples::' static.pro || die
+ fi
+
+ if ! use gui; then
+ sed -i -e '/SUBDIRS += config-ui/ d' src/app/app.pro || die
+ fi
+
+ echo "SUBDIRS = $(usev test auto)" >> tests/tests.pro
+
+ # skip several tests that fail and/or have additional deps
+ sed -i \
+ -e 's/findArchiver(binaryName,.*/"";/' `# requires zip and jar` \
+ -e 's/p\.value("nodejs\./true||&/' `# requires nodejs, bug 527652` \
+ -e 's/\(p\.value\|m_qbsStderr\.contains\)("typescript\./true||&/' `# requires nodejs and typescript` \
+ tests/auto/blackbox/tst_blackbox.cpp || die
+ sed -i -re '/blackbox-(android|apple|java)\.pro/ d' tests/auto/auto.pro || die
+}
+
+src_configure() {
+ local myqmakeargs=(
+ qbs.pro # bug 523218
+ -recursive
+ CONFIG+=qbs_disable_rpath
+ CONFIG+=qbs_enable_project_file_updates
+ $(usev test 'CONFIG+=qbs_enable_unit_tests')
+ QBS_INSTALL_PREFIX="${EPREFIX}/usr"
+ QBS_LIBRARY_DIRNAME="$(get_libdir)"
+ )
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_test() {
+ einfo "Setting up test environment in ${T}"
+
+ export HOME=${T}
+ export LD_LIBRARY_PATH=${S}/$(get_libdir)
+ export QBS_AUTOTEST_PROFILE=testProfile
+
+ "${S}"/bin/qbs-setup-toolchains "$(tc-getCC)" testToolchain || die
+ "${S}"/bin/qbs-setup-qt "$(qt5_get_bindir)/qmake" ${QBS_AUTOTEST_PROFILE} || die
+ "${S}"/bin/qbs-config profiles.${QBS_AUTOTEST_PROFILE}.qbs.targetPlatform linux || die
+
+ einfo "Running autotests"
+
+ # simply exporting LD_LIBRARY_PATH doesn't work
+ # we have to use a custom testrunner script
+ local testrunner=${WORKDIR}/gentoo-testrunner
+ cat <<-EOF > "${testrunner}"
+ #!/bin/sh
+ export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}\${LD_LIBRARY_PATH:+:}\${LD_LIBRARY_PATH}"
+ exec "\$@"
+ EOF
+ chmod +x "${testrunner}"
+
+ emake TESTRUNNER="'${testrunner}'" check
+}
+
+src_install() {
+ emake -j1 INSTALL_ROOT="${D}" install
+
+ dodoc -r changelogs CONTRIBUTING.md README.md
+
+ # install documentation
+ if use doc; then
+ emake docs
+ dodoc -r doc/qbs/html
+ dodoc doc/qbs.qch
+ docompress -x /usr/share/doc/${PF}/qbs.qch
+ fi
+}