summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Lopatin <alopatindev@gmail.com>2016-12-29 12:12:28 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-01-02 10:59:37 +0100
commit98319e06830ea708d7946b18a5d8f4888e74fb3e (patch)
treef0b80843dfb15a3611f051dd455615e3a6d416d9 /dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild
parentdev-python/python-editor: version bump to 1.0.3. (diff)
downloadgentoo-98319e06830ea708d7946b18a5d8f4888e74fb3e.tar.gz
gentoo-98319e06830ea708d7946b18a5d8f4888e74fb3e.tar.bz2
gentoo-98319e06830ea708d7946b18a5d8f4888e74fb3e.zip
dev-util/qdevicemonitor: new package.
QDeviceMonitor is a crossplatform log viewer for Android, iOS and text files. Written in C++ using the Qt5 framework. Gentoo-Bug: https://bugs.gentoo.org/532898 Gentoo-Bug: https://bugs.gentoo.org/603810 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3272
Diffstat (limited to 'dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild')
-rw-r--r--dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild b/dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild
new file mode 100644
index 000000000000..eb497b2dae79
--- /dev/null
+++ b/dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="6"
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Crossplatform log viewer for Android, iOS and text files"
+HOMEPAGE="https://github.com/alopatindev/qdevicemonitor"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/alopatindev/qdevicemonitor"
+else
+ SRC_URI="https://github.com/alopatindev/qdevicemonitor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-util/android-tools
+ app-pda/usbmuxd"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cd "${PN}" || die
+ export VERSION_WITH_BUILD_NUMBER="${PV}"
+ eqmake5
+}
+
+src_compile() {
+ cd "${PN}" || die
+ emake
+}
+
+src_install() {
+ dobin "${PN}/${PN}"
+ dodoc README.md
+ newicon -s scalable "icons/app_icon.svg" "${PN}.svg"
+ domenu "icons/${PN}.desktop"
+}