summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Lopatin <alopatindev@gmail.com>2020-07-11 17:48:51 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-11 18:21:32 +0200
commit20fec9d5384f9cb3108768fa481350ba9c463ad8 (patch)
treea62cb2e0fede4010dff10ef9b8a0c2381bda8f78 /dev-util/qdevicemonitor
parentdev-ruby/rchardet: ppc keyworded (bug #724386) (diff)
downloadgentoo-20fec9d5384f9cb3108768fa481350ba9c463ad8.tar.gz
gentoo-20fec9d5384f9cb3108768fa481350ba9c463ad8.tar.bz2
gentoo-20fec9d5384f9cb3108768fa481350ba9c463ad8.zip
dev-util/qdevicemonitor: fix build with Qt 5.15
Closes: https://bugs.gentoo.org/732088 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexander Lopatin <alopatindev@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16664 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/qdevicemonitor')
-rw-r--r--dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-endl-is-deprecated.patch27
-rw-r--r--dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-endl-is-deprecated.patch b/dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-endl-is-deprecated.patch
new file mode 100644
index 000000000000..27acb5d8ffba
--- /dev/null
+++ b/dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-endl-is-deprecated.patch
@@ -0,0 +1,27 @@
+From 9808ae3279e5816dcc85cf8f21158ecf842dc185 Mon Sep 17 00:00:00 2001
+From: Alexander Lopatin <alopatindev@gmail.com>
+Date: Sat, 11 Jul 2020 03:18:14 +0300
+Subject: [PATCH] Fix "dev-util/qdevicemonitor-1.0.1-r2 : main.cpp: error:
+ QTextStream& QTextStreamFunctions::endl(QTextStream&) is deprecated: Use
+ Qt::endl [-Werror=deprecated-declarations]" https://bugs.gentoo.org/732088
+
+---
+ qdevicemonitor/main.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/qdevicemonitor/main.cpp b/qdevicemonitor/main.cpp
+index 46f80a5..9d3fe73 100644
+--- a/qdevicemonitor/main.cpp
++++ b/qdevicemonitor/main.cpp
+@@ -43,7 +43,7 @@ void logOutput(QtMsgType type, const QMessageLogContext& context, const QString&
+ << ")";
+ }
+
+- out << endl;
++ out << Qt::endl;
+ }
+
+ int main(int argc, char* argv[])
+--
+2.26.2
+
diff --git a/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild
index fd543ed3980a..9debed761814 100644
--- a/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild
+++ b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild
@@ -31,6 +31,7 @@ PATCHES=(
"${FILESDIR}"/${P}-qt-5.11.patch
"${FILESDIR}"/${P}-crash-after-fresh-install.patch
"${FILESDIR}"/${P}-screen-geometry-is-deprecated.patch
+ "${FILESDIR}"/${P}-endl-is-deprecated.patch
)
src_configure() {