summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/qfsm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/qfsm')
-rw-r--r--dev-util/qfsm/Manifest2
-rw-r--r--dev-util/qfsm/metadata.xml11
-rw-r--r--dev-util/qfsm/qfsm-0.53.0.ebuild41
-rw-r--r--dev-util/qfsm/qfsm-0.54.0.ebuild42
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-util/qfsm/Manifest b/dev-util/qfsm/Manifest
new file mode 100644
index 000000000000..114cccbdb195
--- /dev/null
+++ b/dev-util/qfsm/Manifest
@@ -0,0 +1,2 @@
+DIST qfsm-0.53.0-Source.tar.bz2 1498547 SHA256 a47f2f85fc15992a41ae06560fdc0ddbd663488821af6a34d2f0a3a87c4ba9bb SHA512 c9ad1784b1e5edd8f2ba1a24fa2555438de52294dbe39db84820f754bc170806fe999ba3cf14bc743c9753756202edf7581646e677f31e8fb16df1428284a537 WHIRLPOOL b7081dbc783fbc20dea8e1704815a4d118d0636722b67775605ba32a482d1859094ff9f7f03d53e4145802637328f904e6c8f0aa44b5fdfcc46f8c24d276f056
+DIST qfsm-0.54.0-Source.tar.bz2 2130183 SHA256 2b53b7e54e42d4c188f62220aaae3d3fb5e8239b8ac8e88f793689cc0a5b8766 SHA512 ab1f427c6d3421de924070a9fdca5aab2c2cf29dfad1b9f2cd35cbc35542238015a13bb91457de6872fe18f25e41720642bb58a22f33e4d0f56f9067ec8e9507 WHIRLPOOL 1a49150bd5bde7ac0f2d71b65e71523fbc3c5b40b7da593590f2bc78953f056ee410fc4d2c0372f7e33763a34a4252f8b0c890b06706dc2fcd03e3c65cf52c60
diff --git a/dev-util/qfsm/metadata.xml b/dev-util/qfsm/metadata.xml
new file mode 100644
index 000000000000..b125e2fd9521
--- /dev/null
+++ b/dev-util/qfsm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">qfsm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/qfsm/qfsm-0.53.0.ebuild b/dev-util/qfsm/qfsm-0.53.0.ebuild
new file mode 100644
index 000000000000..723fc702bb38
--- /dev/null
+++ b/dev-util/qfsm/qfsm-0.53.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P="${P}-Source"
+
+inherit cmake-utils
+
+DESCRIPTION="A graphical tool for designing finite state machines"
+HOMEPAGE="http://qfsm.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib
+ >=dev-qt/qtcore-4.7:4
+ >=dev-qt/qt3support-4.7:4
+ >=dev-qt/qtsvg-4.7:4
+ <media-gfx/graphviz-2.28.0"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( ChangeLog README TODO )
+
+# TODO: fix doc building, probably some dependencies are missing
+src_prepare()
+{
+ # remove broken pre-generated Makefile
+ rm Makefile || die 'rm Makefile failed'
+ # fix desktop files
+ sed -i -e '/Encoding/d' \
+ -e 's/\.png//' \
+ desktop/qfsm.desktop || die 'sed on qfsm.desktop failed'
+ # fix doc path installation, bug #130641
+ sed -i -e "s:share/doc/qfsm:share/doc/${P}/html:g" CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+}
diff --git a/dev-util/qfsm/qfsm-0.54.0.ebuild b/dev-util/qfsm/qfsm-0.54.0.ebuild
new file mode 100644
index 000000000000..de83220dad23
--- /dev/null
+++ b/dev-util/qfsm/qfsm-0.54.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${P}-Source"
+
+inherit cmake-utils
+
+DESCRIPTION="A graphical tool for designing finite state machines"
+HOMEPAGE="http://qfsm.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib
+ dev-qt/qtcore:4
+ dev-qt/qt3support:4
+ dev-qt/qtsvg:4
+ >=media-gfx/graphviz-2.36"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( ChangeLog README TODO )
+
+src_prepare()
+{
+ # remove broken pre-generated Makefile
+ rm Makefile || die 'rm Makefile failed'
+ # fix desktop files
+ sed -i -e '/Encoding/d' \
+ -e 's/\.png//' \
+ desktop/qfsm.desktop || die 'sed on qfsm.desktop failed'
+ # fix doc path installation, bug #130641
+ sed -i -e "s:share/doc/qfsm:share/doc/${P}/html:g" CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+
+ cmake-utils_src_prepare
+}