summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2017-10-10 22:15:21 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2017-10-12 12:14:44 +0100
commitee8b518b56ddd8670f660cb673fdca14f22678e0 (patch)
tree857ed0504ca1dc7efcd05b579bfa4493ebee25e5 /dev-util/radare2/radare2-9999.ebuild
parentdev-libs/capstone: keyworded for ~arm64 (thanks to Dan Robertson), bug #633892 (diff)
downloadgentoo-ee8b518b56ddd8670f660cb673fdca14f22678e0.tar.gz
gentoo-ee8b518b56ddd8670f660cb673fdca14f22678e0.tar.bz2
gentoo-ee8b518b56ddd8670f660cb673fdca14f22678e0.zip
dev-util/radare2: bump to 2.0.0
Closes: https://github.com/gentoo/gentoo/pull/5908 Closes: https://bugs.gentoo.org/633892
Diffstat (limited to 'dev-util/radare2/radare2-9999.ebuild')
-rw-r--r--dev-util/radare2/radare2-9999.ebuild36
1 files changed, 29 insertions, 7 deletions
diff --git a/dev-util/radare2/radare2-9999.ebuild b/dev-util/radare2/radare2-9999.ebuild
index 4c5adb60d123..cf3939d92997 100644
--- a/dev-util/radare2/radare2-9999.ebuild
+++ b/dev-util/radare2/radare2-9999.ebuild
@@ -3,18 +3,23 @@
EAPI=6
-is_live() { [[ ${PV} == 9999* ]]; }
+inherit eutils
-is_live && inherit git-r3
-
-DESCRIPTION="Advanced command line hexadecimal editor and more"
+DESCRIPTION="unix-like reverse engineering framework and commandline tools"
HOMEPAGE="http://www.radare.org"
-is_live || SRC_URI="http://www.radare.org/get/${P}.tar.xz"
-EGIT_REPO_URI="https://github.com/radare/radare2"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/radare/radare2"
+else
+ SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+ PATCHES=( "${FILESDIR}"/${PN}-0.9.9-nogit.patch )
+fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="ssl +system-capstone"
+IUSE="ssl +system-capstone zsh-completion"
RDEPEND="
ssl? ( dev-libs/openssl:0= )
@@ -29,3 +34,20 @@ src_configure() {
$(use_with ssl openssl) \
$(use_with system-capstone syscapstone)
}
+
+src_install() {
+ default
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins doc/zsh/_*
+ fi
+
+ # a workaround for unstable $(INSTALL) call, bug #574866
+ local d
+ for d in doc/*; do
+ if [[ -d $d ]]; then
+ rm -rfv "$d" || die "failed to delete '$d'"
+ fi
+ done
+}