summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-11-07 16:45:12 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-11-07 16:46:45 -0800
commit2e64fac3ab38977f38dfd09d0f29ec3219c1e3d6 (patch)
tree60a9a2e04ca04077a8b4567c122140e6de15a6ff /dev-util/rats/rats-2.4.ebuild
parentnet-misc/memcached: clean up old 1.2/1.3 series that no longer build, as well... (diff)
downloadgentoo-2e64fac3ab38977f38dfd09d0f29ec3219c1e3d6.tar.gz
gentoo-2e64fac3ab38977f38dfd09d0f29ec3219c1e3d6.tar.bz2
gentoo-2e64fac3ab38977f38dfd09d0f29ec3219c1e3d6.zip
dev-util/rats: version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-util/rats/rats-2.4.ebuild')
-rw-r--r--dev-util/rats/rats-2.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/rats/rats-2.4.ebuild b/dev-util/rats/rats-2.4.ebuild
new file mode 100644
index 000000000000..e536a6cfee83
--- /dev/null
+++ b/dev-util/rats/rats-2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils
+
+DESCRIPTION="RATS - Rough Auditing Tool for Security"
+HOMEPAGE="https://code.google.com/p/rough-auditing-tool-for-security/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/rough-auditing-tool-for-security/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-libs/expat"
+
+src_prepare() {
+ edos2unix $(find "${S}" -name '*.[chl]' -o -name '*.in' -o -name '*.am')
+ #epatch "${FILESDIR}"/${PN}-2.1-add-getopt-trailing-null.patch
+ #epatch "${FILESDIR}"/${PN}-2.1-fix-null-pointers.patch
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX}/usr/share/${PN}/"
+}
+
+src_install () {
+ einstall SHAREDIR="${ED}/usr/share/${PN}" MANDIR="${ED}/usr/share/man"
+ dodoc README README.win32
+}
+
+pkg_postinst() {
+ ewarn "Please be careful when using this program with it's force language"
+ ewarn "option, '--language <LANG>' it may take huge amounts of memory when"
+ ewarn "it tries to treat binary files as some other type."
+}