summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-02-08 10:02:53 +0100
committerDirkjan Ochtman <djc@gentoo.org>2016-02-08 10:04:35 +0100
commit18371609d16cb8f26af16c07c242aa10f7254f41 (patch)
tree59ea155655798794260a92f60d34d0aa98b9fc73 /dev-util/rebar
parentdev-util/rebar: remove old versions (diff)
downloadgentoo-18371609d16cb8f26af16c07c242aa10f7254f41.tar.gz
gentoo-18371609d16cb8f26af16c07c242aa10f7254f41.tar.bz2
gentoo-18371609d16cb8f26af16c07c242aa10f7254f41.zip
dev-util/rebar: version bump to 2.6.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-util/rebar')
-rw-r--r--dev-util/rebar/rebar-2.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/rebar/rebar-2.6.1.ebuild b/dev-util/rebar/rebar-2.6.1.ebuild
new file mode 100644
index 000000000000..bd9cf0c839bd
--- /dev/null
+++ b/dev-util/rebar/rebar-2.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/rebar/rebar"
+SRC_URI="https://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}