summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-12-05 20:31:38 +0100
committerCraig Andrews <candrews@gentoo.org>2020-12-05 14:36:25 -0500
commitac123a292ae9ca8b495ed3f63295772232892061 (patch)
tree2a80a961c1134835dfe16a1805f714359c96ba73 /dev-util/rocm-cmake/rocm-cmake-3.10.0.ebuild
parentdev-libs/roct-thunk-interface: Version bump to 3.10.0 (diff)
downloadgentoo-ac123a292ae9ca8b495ed3f63295772232892061.tar.gz
gentoo-ac123a292ae9ca8b495ed3f63295772232892061.tar.bz2
gentoo-ac123a292ae9ca8b495ed3f63295772232892061.zip
dev-util/rocm-cmake: Version bump to 3.10.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.9, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18520 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/rocm-cmake/rocm-cmake-3.10.0.ebuild')
-rw-r--r--dev-util/rocm-cmake/rocm-cmake-3.10.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/rocm-cmake/rocm-cmake-3.10.0.ebuild b/dev-util/rocm-cmake/rocm-cmake-3.10.0.ebuild
new file mode 100644
index 000000000000..a8e68baa5599
--- /dev/null
+++ b/dev-util/rocm-cmake/rocm-cmake-3.10.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocm-cmake/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/rocm-cmake/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/rocm-cmake-rocm-${PV}"
+fi
+
+DESCRIPTION="Radeon Open Compute CMake Modules"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm-cmake"
+LICENSE="MIT"
+SLOT="0"
+RESTRICT="test"
+
+src_prepare() {
+ sed -e "s:set(ROCM_INSTALL_LIBDIR lib):set(ROCM_INSTALL_LIBDIR $(get_libdir)):" -i "${S}/share/rocm/cmake/ROCMInstallTargets.cmake" || die
+ cmake_src_prepare
+}