summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-05 00:31:32 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-05 00:58:09 +0200
commitc74ae2589a6140d0ae634c3c6a93b49613fc278a (patch)
tree52e0d9b2a7015b53e90698db26647887cbb3cad2 /dev-util/setconf/setconf-0.6.7.ebuild
parentdev-util/huc: clean up old. (diff)
downloadgentoo-c74ae2589a6140d0ae634c3c6a93b49613fc278a.tar.gz
gentoo-c74ae2589a6140d0ae634c3c6a93b49613fc278a.tar.bz2
gentoo-c74ae2589a6140d0ae634c3c6a93b49613fc278a.zip
dev-util/setconf: fix shebang.
Gentoo-Bug: https://bugs.gentoo.org/617268 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/setconf/setconf-0.6.7.ebuild')
-rw-r--r--dev-util/setconf/setconf-0.6.7.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-util/setconf/setconf-0.6.7.ebuild b/dev-util/setconf/setconf-0.6.7.ebuild
index bd589375e9c8..b0646c4fed59 100644
--- a/dev-util/setconf/setconf-0.6.7.ebuild
+++ b/dev-util/setconf/setconf-0.6.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -12,7 +12,6 @@ SRC_URI="http://${PN}.roboticoverlords.org/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND=${PYTHON_DEPS}
@@ -25,16 +24,16 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd "${S}"
- unpack ./${PN}.1.gz
+ cd "${S}" || die
+ unpack "./${PN}.1.gz"
}
src_prepare() {
- python_fix_shebang ${PN}.py #462326
+ python_fix_shebang -f "${PN}.py"
}
src_install() {
- python_doscript ${PN}.py
- dosym ${PN}.py /usr/bin/${PN}
- doman ${PN}.1
+ python_doscript "${PN}.py"
+ dosym "${PN}.py" "/usr/bin/${PN}"
+ doman "${PN}.1"
}