summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-25 08:57:27 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-25 08:57:43 +0000
commit4cbb7c1985252d425134eea97df88504a2fec874 (patch)
treecddda472ad9c996016bf5eb4047609978258981f /dev-util/shards/shards-0.7.1.ebuild
parentdev-util/creduce: Fix gen name to be lowercase (diff)
downloadgentoo-4cbb7c1985252d425134eea97df88504a2fec874.tar.gz
gentoo-4cbb7c1985252d425134eea97df88504a2fec874.tar.bz2
gentoo-4cbb7c1985252d425134eea97df88504a2fec874.zip
dev-util/shards: bump up to 0.7.1
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-util/shards/shards-0.7.1.ebuild')
-rw-r--r--dev-util/shards/shards-0.7.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/shards/shards-0.7.1.ebuild b/dev-util/shards/shards-0.7.1.ebuild
new file mode 100644
index 000000000000..826681b8ad53
--- /dev/null
+++ b/dev-util/shards/shards-0.7.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards"
+SRC_URI="https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >dev-lang/crystal-0.11.1[yaml]
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test # missing files in tarball
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}