summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-23 20:12:50 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-23 20:12:50 +0200
commitf3d2ae135b0930c1165059b92e18cee51dfd17de (patch)
tree60ddcfdcdd844d16caa9456831af74556f9ea066 /dev-util/smem
parentx11-misc/xflux-gui: use correct homepage (diff)
downloadgentoo-f3d2ae135b0930c1165059b92e18cee51dfd17de.tar.gz
gentoo-f3d2ae135b0930c1165059b92e18cee51dfd17de.tar.bz2
gentoo-f3d2ae135b0930c1165059b92e18cee51dfd17de.zip
dev-util/smem: use upstream archive
Since upstreams git system is working again, we can now use upstreams archive for latest 1.5 version. It's identical to the one hosted by me, with one difference, that a README file is not included. Rest is identical including main program. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util/smem')
-rw-r--r--dev-util/smem/Manifest1
-rw-r--r--dev-util/smem/smem-1.5-r1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/smem/Manifest b/dev-util/smem/Manifest
index 32aab828445f..32e33762c950 100644
--- a/dev-util/smem/Manifest
+++ b/dev-util/smem/Manifest
@@ -1 +1,2 @@
+DIST smem-1.5.tar.bz2 15443 BLAKE2B 31fc73b4e74c08a39957983fb02347ad18fae7a50aee8d8a259e15436911967c56e9ce14a4c89ccc3072d49d802c2b3268792992587170b795b7a08b1678d208 SHA512 bf21536294f1b84e3cc40cbed3077f30f5a1c911fd983cf6f7d7bd3f1bc6e3c4cc9ba509daa8da8f6a12ec2df63b25772a070d80cd45ee289a0725565c89a344
DIST smem-1.5.tar.xz 16016 BLAKE2B 7c7e5dae6b047780275eebe2b9ec4fb06b27b8d3d2e70fc50c07136c18d414d7f51203760ab3bca98906c6566633c908dd18a7a8c390339850d80ad1ffe7f188 SHA512 8f3f5447060e6d857c3eb59ccbebbd62f18280f3993b31e55369b31ea74bc0e54109fd6d3f7088a23c48af050ff67eb738efceb0adeaff1dc7466f50efd9bc82
diff --git a/dev-util/smem/smem-1.5-r1.ebuild b/dev-util/smem/smem-1.5-r1.ebuild
new file mode 100644
index 000000000000..32f2b1d30bff
--- /dev/null
+++ b/dev-util/smem/smem-1.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="2ab5040d5633"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils python-single-r1 toolchain-funcs
+
+DESCRIPTION="A tool that can give numerous reports on memory usage on Linux systems"
+HOMEPAGE="https://www.selenic.com/smem/"
+SRC_URI="https://selenic.com/repo/${PN}/archive/${EGIT_COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_compile() {
+ "$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -o smemcap smemcap.c || die
+}
+
+src_install() {
+ dobin smemcap
+ python_doexe smem
+
+ doman smem.8
+}
+
+pkg_postinst() {
+ optfeature "for chart generation." dev-python/matplotlib
+}