summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-08 20:43:39 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-08 20:44:27 +0200
commita20f82824bff15ec83702f07697f3b2433a17e5c (patch)
tree25b91a90b36f1ee2d94247ea8577ca2aaec51a83 /dev-util/source-highlight/source-highlight-3.1.8.ebuild
parentx11-libs/gtk+: version bump from 2.24.31 to 2.24.31-r1 (diff)
downloadgentoo-a20f82824bff15ec83702f07697f3b2433a17e5c.tar.gz
gentoo-a20f82824bff15ec83702f07697f3b2433a17e5c.tar.bz2
gentoo-a20f82824bff15ec83702f07697f3b2433a17e5c.zip
dev-util/source-highlight: Version bump to 3.1.8
Gentoo-bug: 507112, 579002, 582694, 582696 * EAPI=6 * Build using C++14 mode (due to boost-1.62) Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-util/source-highlight/source-highlight-3.1.8.ebuild')
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.8.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/source-highlight/source-highlight-3.1.8.ebuild b/dev-util/source-highlight/source-highlight-3.1.8.ebuild
new file mode 100644
index 000000000000..99bb2f47a670
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-3.1.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1 flag-o-matic
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="https://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/boost-1.62.0:=[threads]
+ dev-util/ctags"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # required as rev-dep of dev-libs/boost-1.62.0
+ # https://wiki.gentoo.org/wiki/Project:C%2B%2B/Maintaining_ABI
+ append-cxxflags -std=c++14
+
+ econf \
+ --with-boost-regex="boost_regex" \
+ --without-bash-completion \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ use doc && local HTML_DOCS=( doc/*.{html,css,java} )
+ default
+
+ # That's not how we want it
+ rm -rf "${ED%/}"/usr/share/{aclocal,doc} || die
+
+ # package provides .pc file
+ find "${D}" -name '*.la' -delete || die
+
+ dobashcomp completion/source-highlight
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
+ default
+}