summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/source-highlight
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/source-highlight')
-rw-r--r--dev-util/source-highlight/Manifest1
-rw-r--r--dev-util/source-highlight/metadata.xml8
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.7-r2.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/source-highlight/Manifest b/dev-util/source-highlight/Manifest
new file mode 100644
index 000000000000..1442cf946c12
--- /dev/null
+++ b/dev-util/source-highlight/Manifest
@@ -0,0 +1 @@
+DIST source-highlight-3.1.7.tar.gz 1600692 SHA256 e1b2e007cdd94595393d42510e2a84763c36aad3409f0c3087f05fcb50a389e8 SHA512 4a1e733bd06468e6ebd023dfe4a62d7134c35aac311509a61e8d80de35ff3cea25fb79adb56bfe413ee214bbf4d578b4d4ebdcf1236481d9b83152aff6d7afb8 WHIRLPOOL 3d99a135abef73e865d2729bcbdf47fc7c143aeef91015b73a87d4a129323ca95aac153c3fa7d5207afb2a03ecba2f05db3e3ed8627b1e0477dcd9dfa830bbb7
diff --git a/dev-util/source-highlight/metadata.xml b/dev-util/source-highlight/metadata.xml
new file mode 100644
index 000000000000..5b2a5c55470b
--- /dev/null
+++ b/dev-util/source-highlight/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/source-highlight/source-highlight-3.1.7-r2.ebuild b/dev-util/source-highlight/source-highlight-3.1.7-r2.ebuild
new file mode 100644
index 000000000000..ce23c9f7a9e3
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-3.1.7-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit bash-completion-r1 versionator
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="http://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+SLOT="0"
+IUSE="doc static-libs"
+
+DEPEND=">=dev-libs/boost-1.52.0-r1[threads]
+ dev-util/ctags"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --with-boost-regex="boost_regex" \
+ --without-bash-completion \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ DOCS="AUTHORS ChangeLog CREDITS NEWS README THANKS TODO.txt"
+ default
+
+ use static-libs || rm -rf "${D}"/usr/lib*/*.la
+
+ dobashcomp completion/source-highlight
+
+ # That's not how we want it
+ rm -fr "${ED}/usr/share"/{aclocal,doc}
+ use doc && dohtml -A java doc/*.{html,css,java}
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
+ default
+}