summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/spec-cleaner
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/spec-cleaner')
-rw-r--r--dev-util/spec-cleaner/Manifest1
-rw-r--r--dev-util/spec-cleaner/metadata.xml8
-rw-r--r--dev-util/spec-cleaner/spec-cleaner-0.7.1.ebuild44
-rw-r--r--dev-util/spec-cleaner/spec-cleaner-9999.ebuild44
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-util/spec-cleaner/Manifest b/dev-util/spec-cleaner/Manifest
new file mode 100644
index 000000000000..11d7aee49d72
--- /dev/null
+++ b/dev-util/spec-cleaner/Manifest
@@ -0,0 +1 @@
+DIST spec-cleaner-0.7.1.tar.gz 80410 SHA256 880db846c443ef6bcc9b3f2ed871eeafc91987b3ee0deb6ae08fd601be7c9291 SHA512 1ec7c69e84ca8075e1580d64e090d871594af177fde7bbdc12ab721d62d1180d04fdc13cd771326cca47a504169ae0de62d5b46cb3f217bcd755e7ff67f0a32b WHIRLPOOL 84bf96b7ec5c110ba1e513811c9aa6a09af3c344da8cb7781025d8bd0eb679c316037f379c729dc45613e3215e1ab8fb70ed454c37a5b2d20a181cef9baa5def
diff --git a/dev-util/spec-cleaner/metadata.xml b/dev-util/spec-cleaner/metadata.xml
new file mode 100644
index 000000000000..12ec8af3d77a
--- /dev/null
+++ b/dev-util/spec-cleaner/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>suse</herd>
+ <upstream>
+ <remote-id type="github">openSUSE/spec-cleaner</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/spec-cleaner/spec-cleaner-0.7.1.ebuild b/dev-util/spec-cleaner/spec-cleaner-0.7.1.ebuild
new file mode 100644
index 000000000000..20592dcd5458
--- /dev/null
+++ b/dev-util/spec-cleaner/spec-cleaner-0.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+EGIT_REPO_URI="https://github.com/openSUSE/spec-cleaner.git"
+inherit distutils-r1
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="SUSE spec file cleaner and formatter"
+HOMEPAGE="https://github.com/openSUSE/spec-cleaner"
+[[ ${PV} != 9999 ]] && SRC_URI="https://github.com/openSUSE/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+[[ ${PV} != 9999 ]] && \
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+
+[[ ${PV} != 9999 ]] && S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ # we have libexec
+ sed -i \
+ -e 's:lib/obs:libexec/obs:g' \
+ setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ nosetests
+}
diff --git a/dev-util/spec-cleaner/spec-cleaner-9999.ebuild b/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
new file mode 100644
index 000000000000..20592dcd5458
--- /dev/null
+++ b/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+EGIT_REPO_URI="https://github.com/openSUSE/spec-cleaner.git"
+inherit distutils-r1
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="SUSE spec file cleaner and formatter"
+HOMEPAGE="https://github.com/openSUSE/spec-cleaner"
+[[ ${PV} != 9999 ]] && SRC_URI="https://github.com/openSUSE/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+[[ ${PV} != 9999 ]] && \
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+
+[[ ${PV} != 9999 ]] && S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ # we have libexec
+ sed -i \
+ -e 's:lib/obs:libexec/obs:g' \
+ setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ nosetests
+}