summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/squashmerge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/squashmerge')
-rw-r--r--dev-util/squashmerge/Manifest1
-rw-r--r--dev-util/squashmerge/metadata.xml19
-rw-r--r--dev-util/squashmerge/squashmerge-0.1.ebuild37
-rw-r--r--dev-util/squashmerge/squashmerge-9999.ebuild49
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-util/squashmerge/Manifest b/dev-util/squashmerge/Manifest
new file mode 100644
index 000000000000..85828b894243
--- /dev/null
+++ b/dev-util/squashmerge/Manifest
@@ -0,0 +1 @@
+DIST squashmerge-0.1.tar.bz2 76678 SHA256 f4c1c16ae91517191f64718f9e2e0d1f89efcbe56280b70d5c82e2b2f0447d3d SHA512 a12e78d79a3f212a65c0b979a1ca3de9532ebf33f891ae2fd216425cd044a6f3357496e9f37bebc53a067aa592f7a1eecdeee653929eb443426e48fe342c7683 WHIRLPOOL c559f79a8d43e9cf30a8850d62e6c9e374f32ea4bdb10f168b8ce7aef2a0b11b50c4c54e776a703628810cb8d9e7d6c323ab8378d1ac9f0c0b5c6f55d0589071
diff --git a/dev-util/squashmerge/metadata.xml b/dev-util/squashmerge/metadata.xml
new file mode 100644
index 000000000000..6973616f95ce
--- /dev/null
+++ b/dev-util/squashmerge/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="lz4">Enable support for LZ4 compression using <pkg>app-arch/lz4</pkg></flag>
+ </use>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/squashmerge/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/squashmerge</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/squashmerge/squashmerge-0.1.ebuild b/dev-util/squashmerge/squashmerge-0.1.ebuild
new file mode 100644
index 000000000000..cafb308e5c6a
--- /dev/null
+++ b/dev-util/squashmerge/squashmerge-0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="dev-util/squashdelta delta merge tool"
+HOMEPAGE="https://bitbucket.org/mgorny/squashmerge/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+DOCS=( FORMAT )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/squashmerge/squashmerge-9999.ebuild b/dev-util/squashmerge/squashmerge-9999.ebuild
new file mode 100644
index 000000000000..bda7ce79054e
--- /dev/null
+++ b/dev-util/squashmerge/squashmerge-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="dev-util/squashdelta delta merge tool"
+HOMEPAGE="https://bitbucket.org/mgorny/squashmerge/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+DOCS=( FORMAT )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ autotools-utils_src_configure
+}