summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-11-29 22:35:12 +0100
committerDavid Seifert <soap@gentoo.org>2018-11-29 22:36:04 +0100
commit461a0284d5e3d05988b20e43411c93330d41ee67 (patch)
tree3f31b41c06473b8dc71e6d932cf101fdc7ef2bb9 /dev-util/statifier/statifier-1.7.4.ebuild
parentmedia-libs/mediastreamer: Fix build with ffmpeg-4 (diff)
downloadgentoo-461a0284d5e3d05988b20e43411c93330d41ee67.tar.gz
gentoo-461a0284d5e3d05988b20e43411c93330d41ee67.tar.bz2
gentoo-461a0284d5e3d05988b20e43411c93330d41ee67.zip
dev-util/statifier: [QA] Honour CC flags
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/statifier/statifier-1.7.4.ebuild')
-rw-r--r--dev-util/statifier/statifier-1.7.4.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-util/statifier/statifier-1.7.4.ebuild b/dev-util/statifier/statifier-1.7.4.ebuild
index 08b4f7afec9b..b4021f0a1cf3 100644
--- a/dev-util/statifier/statifier-1.7.4.ebuild
+++ b/dev-util/statifier/statifier-1.7.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
MULTILIB_COMPAT=( abi_x86_{32,64} )
-inherit multilib-build
+inherit multilib-build toolchain-funcs
DESCRIPTION="Statifier is a tool for creating portable, self-containing Linux executables"
HOMEPAGE="http://statifier.sourceforge.net"
@@ -20,20 +20,23 @@ RDEPEND="app-shells/bash
sys-apps/coreutils
virtual/awk"
-src_prepare() {
+PATCHES=(
# Respect users CFLAGS and LDFLAGS
- sed -i -e 's/-Wall -O2/$(CFLAGS) $(LDFLAGS)/g' src/Makefile || die
+ "${FILESDIR}"/${PN}-1.7.4-fix-build-system.patch
+)
+
+src_prepare() {
+ default
# Don't compile 32-bit on amd64 no-multilib profile
if ! use abi_x86_32; then
sed -i -e 's/ELF32 .*/ELF32 := no/g' configs/config.x86_64 || die
fi
-
- # Apply user patches
- eapply_user
}
src_configure() {
+ tc-export CC
+
# Fix permissions, as configure is not marked executable
chmod +x configure || die
econf