summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-15 09:59:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-15 10:00:06 +0100
commit797d7d2298d3d4a12572471ab79ffede35b8eaa5 (patch)
tree84f1c93eb80898c6898bc174ffb1342bd421048c /dev-util/strace/strace-4.9.ebuild
parentdev-util/strace: Bump to version 4.16 (diff)
downloadgentoo-797d7d2298d3d4a12572471ab79ffede35b8eaa5.tar.gz
gentoo-797d7d2298d3d4a12572471ab79ffede35b8eaa5.tar.bz2
gentoo-797d7d2298d3d4a12572471ab79ffede35b8eaa5.zip
dev-util/strace: Removed old.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/strace/strace-4.9.ebuild')
-rw-r--r--dev-util/strace/strace-4.9.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-util/strace/strace-4.9.ebuild b/dev-util/strace/strace-4.9.ebuild
deleted file mode 100644
index 1c77fe1d6834..000000000000
--- a/dev-util/strace/strace-4.9.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit flag-o-matic eutils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.code.sf.net/p/strace/code"
- EGIT_PROJECT="${PN}"
- inherit git-2 autotools
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
-fi
-
-DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="https://sourceforge.net/projects/strace/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="aio +perl static unwind"
-
-LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
-# strace only uses the header from libaio to decode structs
-DEPEND="static? ( ${LIB_DEPEND} )
- aio? ( >=dev-libs/libaio-0.3.106 )
- sys-kernel/linux-headers"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-
-src_prepare() {
- if epatch_user || [[ ! -e configure ]] ; then
- # git generation
- ./xlat/gen.sh
- eautoreconf
- [[ ! -e CREDITS ]] && cp CREDITS{.in,}
- fi
-
- filter-lfs-flags # configure handles this sanely
- use static && append-ldflags -static
-
- export ac_cv_header_libaio_h=$(usex aio)
-
- # Stub out the -k test since it's known to be flaky. #545812
- sed -i '1iexit 77' tests*/strace-k.test || die
-}
-
-src_configure() {
- econf $(use_with unwind libunwind)
-}
-
-src_install() {
- default
- use perl || rm "${ED}"/usr/bin/strace-graph
- dodoc CREDITS
-}