summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-22 16:34:59 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-22 16:37:02 +0100
commit90b9e08d5f5b4e0f1bf1385a74e8a73f5ba8f23c (patch)
tree02bea1e662c6e1d921e8e84881c3f9afb0ef16f5 /dev-util/strace
parentdev-python/docker-py: Remove old (diff)
downloadgentoo-90b9e08d5f5b4e0f1bf1385a74e8a73f5ba8f23c.tar.gz
gentoo-90b9e08d5f5b4e0f1bf1385a74e8a73f5ba8f23c.tar.bz2
gentoo-90b9e08d5f5b4e0f1bf1385a74e8a73f5ba8f23c.zip
dev-util/strace: Bump to version 4.20
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/Manifest1
-rw-r--r--dev-util/strace/strace-4.20.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index 871e7e8ca4ff..988f92ed0c6d 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -3,3 +3,4 @@ DIST strace-4.16.tar.xz 966668 SHA256 98487cb5178ec1259986cc9f6e2a844f50e5d1208c
DIST strace-4.17.tar.xz 1001808 SHA256 81f35b085fbb3cfa806eb521a8522ac3406deaccfe121ce35064bad268237419 SHA512 dab376d9c5ac7db98e864f3cfb165eeec714e3ea492f32ee873cebe01fbd3a0793db09983af1da6530480666a59973ccd9855d348e754be1eead9c0a5d524029 WHIRLPOOL 5d1aaa0405288695d73523eb0171e9c56e966db44a58dbd7ae6aed16af66a151be5ad58fb716ce2305ea9435e29dc36bd3be5ade73e09fef69fcbcf32599a036
DIST strace-4.18.tar.xz 1040676 SHA256 89ad887c1e6226bdbca8da31d589cadea4be0744b142eb47b768086c937fca08 SHA512 4fcabc11ef8055c09a5a4777e66f006dd9d67d74740dc0d6e31eb16fa8496062b848c1f21adeeeba7895f57af851103a384c19000ac15cd2f5521e78a5e7a8ad WHIRLPOOL 740d8a19ed3cc0822ec3bbdae72dd3cbe892f78a9161ee824735599ac316788a3fa8c54a18ba32b79c6225930e57f9a74f00fd8e11a1b96514bce9b40d124edc
DIST strace-4.19.tar.xz 1113124 SHA256 7c93ebc6c29280f47c24a0eb86873a99ccb2cac6512c60a60ba4ef99ab807281 SHA512 91d57f58ac0e70ff4dcd69fda3cb835de7f40a9152817427e9c264773f99015badbad7bab047ce7f69001b689b1ce54af9522a9738060823de8873bee1e0c629 WHIRLPOOL 426bca505798a70f623f263de2fe3b02ee603ae513523d3b3fe781780ffc31a0a365214f76c1afdcdb32ec72a37178dd342f594fafe596a3c64d3b99ba38f2fb
+DIST strace-4.20.tar.xz 1132460 BLAKE2B 2e0e3080008ed1d5fd87572df740af8c62ebba44e0ece3c6b5ab581f246e79d8074a7fc2d0857abe158a055042fccbd880e11c9567beca1aeddc23f92d763c2d SHA512 869b3b9c48401619073a021e20e80cce37d8884f615bdb52dac9e6a2903df11507d7a0cb0ccad75bcc03d8dfafead0e68d14267e663503e94849079c9a2ebd4c
diff --git a/dev-util/strace/strace-4.20.ebuild b/dev-util/strace/strace-4.20.ebuild
new file mode 100644
index 000000000000..458e7d64d80e
--- /dev/null
+++ b/dev-util/strace/strace-4.20.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/strace/code"
+ EGIT_PROJECT="${PN}"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="https://sourceforge.net/projects/strace/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="aio perl static unwind"
+
+LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
+# strace only uses the header from libaio to decode structs
+DEPEND="
+ static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers
+"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+
+ if [[ ! -e configure ]] ; then
+ # git generation
+ ./xlat/gen.sh || die
+ ./generate_mpers_am.sh || die
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+ use static && append-ldflags -static
+
+ export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
+
+ # Stub out the -k test since it's known to be flaky. #545812
+ sed -i '1iexit 77' tests*/strace-k.test || die
+}
+
+src_configure() {
+ # Set up the default build settings, and then use the names strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
+ econf $(use_with unwind libunwind)
+}
+
+src_install() {
+ default
+ use perl || rm "${ED}"/usr/bin/strace-graph
+ dodoc CREDITS
+}