summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-02-06 22:05:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-02-06 22:11:43 +0100
commitd9fa38d5a9fc8cee637192385c611429500ee5c7 (patch)
tree7cf93fabc65008b6e91a36a30876f98b0d3a27fb /dev-util/strace
parentdev-python/flup: keyworded 1.0.2-r1 for hppa, bug #700918 (diff)
downloadgentoo-d9fa38d5a9fc8cee637192385c611429500ee5c7.tar.gz
gentoo-d9fa38d5a9fc8cee637192385c611429500ee5c7.tar.bz2
gentoo-d9fa38d5a9fc8cee637192385c611429500ee5c7.zip
dev-util/strace: Bump to version 5.5
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/Manifest1
-rw-r--r--dev-util/strace/strace-5.5.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index ea3db906b495..920d075e8101 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -2,3 +2,4 @@ DIST strace-4.26.tar.xz 1444216 BLAKE2B ea8ff5f863afa29a3a40e8d89ff5c3835c64adf7
DIST strace-5.2.tar.xz 1515544 BLAKE2B 919a689741eabd843a43fdb557953ee6095a4d1abea808d7c35049b93afd338e0df7c69014486dfb88d22dd7cdb2f74b939ed55f08e85cdb9793d8150d08bde0 SHA512 41bea20215fa80ad90a5d49c41944e02774e715efda5e563b3714e5800933a5fca4a2392634193cf49c0752321a39e0c185bdbc9cfb8ee053b09a6bd5723da35
DIST strace-5.3.tar.xz 1572708 BLAKE2B 808bc7afc6c70137c44d0f5a47706953bc7c0214348cda2ae45e10876bd6e118c103f15abffdfe0d7fdb01d8d3de163b9c7de3970d9cd07c88ceca11a99dc7f9 SHA512 02b80a8abedb14e40235709733953005210cd328daba59cb594745e7ed3851d155546ccccdb3e43835aa75eee89f023324e542e15154bbc3269e37fd23433e2a
DIST strace-5.4.tar.xz 1599396 BLAKE2B 0a7fd9600488f5f07042ead8123151cf0113f82329c3cc786c8f3ffb8673f73eaaa1a489f1f27c47800a20e5b6327f1bf5fb09a5b798156908f9e10374a04970 SHA512 4ddba2ec4457a2257c18b26dca851e49a275813c4eb3069379a93fcc60228f9b63a3dee9e3719ae606a7cc61d55ab21ce147327223903c302c061e381097a8d7
+DIST strace-5.5.tar.xz 1628744 BLAKE2B ae2ab9b2c756858c3c23640ee19821b8720da84a5e15e4a674768d8f4b51d74b2b490cfa18a862bc3c9d129baeaf09212700bea98ac151db035d03a05afa055d SHA512 317fe6341000b452cf038433c2a9a7bcdc8ce736e97b242673ce066dd9dbd3b2c3435a014b529429fdf2ac8af5c3a72d62971b293d007b7d3efcbb684c216231
diff --git a/dev-util/strace/strace-5.5.ebuild b/dev-util/strace/strace-5.5.ebuild
new file mode 100644
index 000000000000..c6b8e0324fbd
--- /dev/null
+++ b/dev-util/strace/strace-5.5.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strace/strace.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="https://strace.io/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="aio perl static unwind elfutils"
+
+REQUIRED_USE="?? ( unwind elfutils )"
+
+LIB_DEPEND="
+ unwind? ( sys-libs/libunwind[static-libs(+)] )
+ elfutils? ( dev-libs/elfutils[static-libs(+)] )
+"
+# strace only uses the header from libaio to decode structs
+DEPEND="
+ static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers
+"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+
+ # Needed for applied patch (#701516). Remove with next version.
+ # Don't forget about autotools inherit.
+ eautoreconf
+
+ if [[ ! -e configure ]] ; then
+ # git generation
+ sed /autoreconf/d -i bootstrap || die
+ ./bootstrap || die
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+ # Add -pthread since strace wants -lrt for timer_create, and -lrt uses -lpthread.
+ use static && append-ldflags -static -pthread
+
+ export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
+
+ # Stub out the -k test since it's known to be flaky. #545812
+ sed -i '1iexit 77' tests*/strace-k.test || die
+}
+
+src_configure() {
+ # Set up the default build settings, and then use the names strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
+ # Don't require mpers support on non-multilib systems. #649560
+ local myeconfargs=(
+ --enable-mpers=check
+ $(use_with unwind libunwind)
+ $(use_with elfutils libdw)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if has usersandbox ${FEATURES} ; then
+ ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..." #643044
+ return 0
+ fi
+
+ default
+}
+
+src_install() {
+ default
+ if ! use perl ; then
+ rm "${ED}"/usr/bin/strace-graph || die
+ fi
+ dodoc CREDITS
+}