summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 00:03:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-13 00:03:37 +0100
commit76c19eb63eeb77b5f50f3d9fc003a8b7e693e877 (patch)
tree1cd3e0af9d6abb33b886e8c4b47239150309840c /dev-util/stripe-mock
parentdev-ml/gen: fix deps (diff)
downloadgentoo-76c19eb63eeb77b5f50f3d9fc003a8b7e693e877.tar.gz
gentoo-76c19eb63eeb77b5f50f3d9fc003a8b7e693e877.tar.bz2
gentoo-76c19eb63eeb77b5f50f3d9fc003a8b7e693e877.zip
dev-util/stripe-mock: Switch to go-module.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.118.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/stripe-mock-0.118.0-r1.ebuild b/dev-util/stripe-mock/stripe-mock-0.118.0-r1.ebuild
new file mode 100644
index 000000000000..586567a061dc
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.118.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}