summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-24 07:38:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-24 10:23:23 +0200
commit927652351c983ff07debfb5fa448f23c91883d0b (patch)
tree58f7ed22fc5492b63ab698ea9f049a1b99116846 /dev-util/stripe-mock
parentdev-python/Faker: Bump to 8.10.2 (diff)
downloadgentoo-927652351c983ff07debfb5fa448f23c91883d0b.tar.gz
gentoo-927652351c983ff07debfb5fa448f23c91883d0b.tar.bz2
gentoo-927652351c983ff07debfb5fa448f23c91883d0b.zip
dev-util/stripe-mock: Bump to 0.110.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.110.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 0c8ce3e95c8e..f2e98e0b11ee 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -4,3 +4,4 @@ DIST stripe-mock-0.105.0.tar.gz 583483 BLAKE2B 8015699be4cd7a0c6e81c8f89cebe23fa
DIST stripe-mock-0.106.0.tar.gz 592320 BLAKE2B 2154898ecb13516d11fe5188012829af5618a0520b19d6c3899c976ef719e5ddfe0a1bfe0c6787b9e51c695734d90e2297b8df6abc7d055a8d4df8e747d16b08 SHA512 30d5db6ace639435f0c97ce2ff38c02acdb464a09d5cf59a90ea3892b5f277e05ffb67d068b74739c2cdca3e73b2db74054079335bb28536c57457b46251bd6d
DIST stripe-mock-0.107.0.tar.gz 592857 BLAKE2B 6fb58e6c38a04e443adf68bd30dbe16531abede29c104c617bd16f7fd9ce19b38bcd43df2b3fc21e9f8f5cf58a9e6413158f09a0e4746721e29180bfa8e5a26c SHA512 c455f18c242d15e20022fa17a99d4fb33ba93932d6983eb589b4e084b1bd2739a1db837ae70c4043cc4333a5a13ff4f4b16785a9ab014e556901fa975380e90b
DIST stripe-mock-0.109.0.tar.gz 604488 BLAKE2B de84bb5c549628a642c7612b86a5d3266d920e14ba76d7a03055569718cdf05a5ce1d022c645423c11f1ea82849879444c779156bbd59cd91ba89d00176af5eb SHA512 a14d0feb1bd3d191dd184218bb23bb8f7f8fa582a4b66f8dbb8d8c0c028e8757a914cf82ae7b8eaa43be246a3af4fd19744b69d8496816caacb91672fe9b8538
+DIST stripe-mock-0.110.0.tar.gz 604856 BLAKE2B ce8b83ce4787d56752ce47f919c049a32ad0addf67db0461a70fba2380406e5dbaf0e096011a3a371d897d9bd3ef6c573cdec1b66607b0d4b99c3fc11a931d19 SHA512 8501a8d41d0dbba77064abbf083162393453b884bcc9077793d7a75948a925fb056ff37ef74d5d789598d9081639f74016f06980954d3be84a9131ceb21539b2
diff --git a/dev-util/stripe-mock/stripe-mock-0.110.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.110.0.ebuild
new file mode 100644
index 000000000000..05a7220e34b0
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.110.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D}$(get_golibdir_gopath)" || die
+}