summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-18 06:36:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-18 08:47:05 +0200
commite9e5499e24570294eb689fe58fd22608d9694061 (patch)
tree6e789a0c6364d1d3b7684f9105dcdca6521f6bf3 /dev-util/stripe-mock
parentdev-python/django-filter: Bump to 22.1 (diff)
downloadgentoo-e9e5499e24570294eb689fe58fd22608d9694061.tar.gz
gentoo-e9e5499e24570294eb689fe58fd22608d9694061.tar.bz2
gentoo-e9e5499e24570294eb689fe58fd22608d9694061.zip
dev-util/stripe-mock: Bump to 0.135.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.135.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 78e2bf6f52d5..de1ed7542e04 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.130.0.tar.gz 572453 BLAKE2B b97a1b54f4da158140e91abf68c8b476f18d7e96ea96587cd6a54be451776e5066a0dfc2da6c4b7234e08315b646d395f21099b8e30f20b9bce1b3c90f03c199 SHA512 7796ce75a77cf84c475cb8b957b76280ef7ba616dbfdabe2b6fbc4af135c0068777e0acc5f7a0c058a930988f66ae9d08c69a71cf119fadd9a79f210dddf7be5
+DIST stripe-mock-0.135.0.tar.gz 581001 BLAKE2B 7e7b129b5080cca742b1ce08b1a3443f74af23bad3cf09915a7b697f08c4ecb3d0801bd0a1498746cbd5a1f1e4bd4b4fc182f7f4cf0fb39b6db7067c4f8b5a88 SHA512 276dd5f063a1f318349d87314e76f6d6a00f4e694bd7be0f3de8f85195c196d43cf9f17128b156e75b90502ce897835953d5c425684ce7176a3977d4ea0a477e
diff --git a/dev-util/stripe-mock/stripe-mock-0.135.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.135.0.ebuild
new file mode 100644
index 000000000000..89958510a463
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.135.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}