summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/stubgen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/stubgen')
-rw-r--r--dev-util/stubgen/Manifest1
-rw-r--r--dev-util/stubgen/metadata.xml9
-rw-r--r--dev-util/stubgen/stubgen-2.08.ebuild25
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/stubgen/Manifest b/dev-util/stubgen/Manifest
new file mode 100644
index 000000000000..8593b025652c
--- /dev/null
+++ b/dev-util/stubgen/Manifest
@@ -0,0 +1 @@
+DIST stubgen-2.08.tar.gz 104152 SHA256 0a47ebd80dc610afd801195b6f8de9e47331e2723542bd8431c306458066317b SHA512 daf8a83963fbc8b6857036a3f67a25031fc9e5f032ffedb1e041246354ede2363f5324b6f52ffe69fb41caa177eeca0a1c120f235e460043da1db5fb78fa5e41 WHIRLPOOL afde6c1413127a03ef27c5b0aaae72aea88f6f1a96d704f1daa545bcc5ffc6bded394b2afe563fbac8f4004f4f14f21668f440d7597e77a8289e3cbae98a8874
diff --git a/dev-util/stubgen/metadata.xml b/dev-util/stubgen/metadata.xml
new file mode 100644
index 000000000000..fb7ec4a9a25a
--- /dev/null
+++ b/dev-util/stubgen/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/dev-util/stubgen/stubgen-2.08.ebuild b/dev-util/stubgen/stubgen-2.08.ebuild
new file mode 100644
index 000000000000..011fb0ee6776
--- /dev/null
+++ b/dev-util/stubgen/stubgen-2.08.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="a member function stub generator for C++"
+HOMEPAGE="http://www.radwin.org/michael/projects/stubgen/"
+SRC_URI="http://www.radwin.org/michael/projects/${PN}/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_compile() {
+ make CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ChangeLog README
+ doman ${PN}.1
+}