summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/synopsis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/synopsis')
-rw-r--r--dev-util/synopsis/Manifest1
-rw-r--r--dev-util/synopsis/files/synopsis-0.12-gcc45.patch17
-rw-r--r--dev-util/synopsis/metadata.xml7
-rw-r--r--dev-util/synopsis/synopsis-0.13.ebuild52
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/synopsis/Manifest b/dev-util/synopsis/Manifest
new file mode 100644
index 000000000000..941d8ba48548
--- /dev/null
+++ b/dev-util/synopsis/Manifest
@@ -0,0 +1 @@
+DIST synopsis-0.13.tar.gz 10691494 SHA256 8a27f39203d828ace4a122b8bdc4f98e3746af724f88a0d75e1380fe736dbe5f SHA512 cdd84f4b9fc8a7b0edaa017e7a332bba06cd4fc804c49b84b1558a84e814e3a8a4b8c5801a8eaf149e6475dbacbb879f04ade57e31d660dfac5e0c83887abd54 WHIRLPOOL 0198437a19b8871428ddc1bcbbf01cad3b9e660cdb577f48c3542fcffc2b31acbb92ef5938b4e2d4a0404c5db85de9915772e953b93c45505fd8341748222aea
diff --git a/dev-util/synopsis/files/synopsis-0.12-gcc45.patch b/dev-util/synopsis/files/synopsis-0.12-gcc45.patch
new file mode 100644
index 000000000000..ff0fe2be5da8
--- /dev/null
+++ b/dev-util/synopsis/files/synopsis-0.12-gcc45.patch
@@ -0,0 +1,17 @@
+Fixing build with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318429
+
+Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
+
+--- Synopsis/Parsers/Cxx/Types.cc
++++ Synopsis/Parsers/Cxx/Types.cc
+@@ -169,7 +169,7 @@
+ // Class Types::FuncPtr
+ //
+
+-FuncPtr::FuncPtr(Type::Type* ret, const Mods& premods, const Type::vector& params)
++FuncPtr::FuncPtr(Type* ret, const Mods& premods, const Type::vector& params)
+ : m_return(ret), m_premod(premods), m_params(params)
+ {}
+
diff --git a/dev-util/synopsis/metadata.xml b/dev-util/synopsis/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-util/synopsis/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/synopsis/synopsis-0.13.ebuild b/dev-util/synopsis/synopsis-0.13.ebuild
new file mode 100644
index 000000000000..bb62c2cda599
--- /dev/null
+++ b/dev-util/synopsis/synopsis-0.13.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 multilib toolchain-funcs
+
+DESCRIPTION="General source code documentation tool"
+HOMEPAGE="http://synopsis.fresco.org/index.html"
+SRC_URI="http://synopsis.fresco.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-libs/boehm-gc"
+RDEPEND="${COMMON_DEPEND}
+ media-gfx/graphviz"
+DEPEND="${COMMON_DEPEND}
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12-gcc45.patch )
+
+pkg_setup() {
+ tc-export CC CXX
+}
+
+python_prepare() {
+ rm -r src/Synopsis/gc || die "failed to remove bundled lib"
+
+ # the distutils script passes its options to a number of
+ # autoconf scripts, to not all of which these options are
+ # relevant. adding this option disables these useless warnings.
+ sed -e "/self.announce(command)/i\ command += ' --disable-option-checking'" \
+ -i Synopsis/dist/command/config.py || die
+}
+
+python_configure() {
+ local mydistutilsargs=(
+ config
+ --libdir=/usr/$(get_libdir)
+ --with-gc-prefix=/usr
+ )
+ esetup.py
+}