summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/trinity/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/trinity/files')
-rw-r--r--dev-util/trinity/files/trinity-1.1-flags.patch20
-rw-r--r--dev-util/trinity/files/trinity-1.2-btrfs-headers.patch39
-rw-r--r--dev-util/trinity/files/trinity-1.2-videodev2-ioctls.patch40
-rw-r--r--dev-util/trinity/files/trinity-1.4-flags.patch20
-rw-r--r--dev-util/trinity/files/trinity-1.5-flags.patch11
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-util/trinity/files/trinity-1.1-flags.patch b/dev-util/trinity/files/trinity-1.1-flags.patch
new file mode 100644
index 000000000000..fd794c62dc67
--- /dev/null
+++ b/dev-util/trinity/files/trinity-1.1-flags.patch
@@ -0,0 +1,20 @@
+--- trinity-1.1/Makefile
++++ trinity-1.1/Makefile
+@@ -3,7 +3,7 @@
+ INSTALL_PREFIX ?= $(DESTDIR)
+ INSTALL_PREFIX ?= $(HOME)
+
+-CFLAGS = -Wall -W -g -O2 -I. -Wimplicit -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE
++CFLAGS += -Wall -W -I. -Wimplicit -D_GNU_SOURCE
+ #CFLAGS += $(shell if $(CC) -m32 -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-m32"; fi)
+ CFLAGS += -Wdeclaration-after-statement
+ CFLAGS += -Wformat=2
+@@ -49,7 +49,7 @@
+ -include $(SRCS:%.c=$(DEPDIR)/%.d)
+
+ trinity: test $(OBJS) $(HEADERS)
+- $(CC) $(CFLAGS) -o trinity $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o trinity $(OBJS)
+ @mkdir -p tmp
+
+ df = $(DEPDIR)/$(*F)
diff --git a/dev-util/trinity/files/trinity-1.2-btrfs-headers.patch b/dev-util/trinity/files/trinity-1.2-btrfs-headers.patch
new file mode 100644
index 000000000000..81eb170fcbae
--- /dev/null
+++ b/dev-util/trinity/files/trinity-1.2-btrfs-headers.patch
@@ -0,0 +1,39 @@
+From 2f51ba47d4e16aaa877956e2876f81ed50af5c5d Mon Sep 17 00:00:00 2001
+From: Andi Shyti <andi@etezian.org>
+Date: Wed, 24 Jul 2013 12:31:05 +0200
+Subject: [PATCH] ioctls: btrfs-control: fix header inclusion order
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This patch enables newer linux/btrfs.h in Kernel headers 3.11,
+where NULL is not recognized as a define. This is done by
+including stdlib.h before linux/btrfs.h. It gets rid of the
+following compiling error:
+
+In file included from ioctls/btrfs-control.c:5:0:
+/usr/include/linux/btrfs.h: In function ‘btrfs_err_str’:
+/usr/include/linux/btrfs.h:486:11: error: ‘NULL’ undeclared (first use in
+ return NULL;
+ ^
+
+Signed-off-by: Andi Shyti <andi@etezian.org>
+---
+ ioctls/btrfs-control.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ioctls/btrfs-control.c b/ioctls/btrfs-control.c
+index 35e5389..3b0b50a 100644
+--- a/ioctls/btrfs-control.c
++++ b/ioctls/btrfs-control.c
+@@ -2,6 +2,7 @@
+
+ #ifdef USE_BTRFS
+
++#include <stdlib.h>
+ #include <linux/btrfs.h>
+
+ #include "trinity.h"
+--
+1.8.3.2
+
diff --git a/dev-util/trinity/files/trinity-1.2-videodev2-ioctls.patch b/dev-util/trinity/files/trinity-1.2-videodev2-ioctls.patch
new file mode 100644
index 000000000000..c7240b7c15c0
--- /dev/null
+++ b/dev-util/trinity/files/trinity-1.2-videodev2-ioctls.patch
@@ -0,0 +1,40 @@
+From 54c5f3cce91ed914b1abbd3bafe4877e413947fa Mon Sep 17 00:00:00 2001
+From: Andi Shyti <andi@etezian.org>
+Date: Wed, 24 Jul 2013 00:42:07 +0200
+Subject: [PATCH] ioctls: videodev2: check if defines are obsolete
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+In kernel headers 3.11 the VIDIOC_DBG_G_CHIP_IDENT define is
+considered obsolete, therefore removed, generating the following
+compiling error:
+
+ioctls/videodev2.c:72:15: error: ‘VIDIOC_DBG_G_CHIP_IDENT’ undeclared here (not in a function)
+ IOCTL(VIDIOC_DBG_G_CHIP_IDENT),
+ ^
+
+Check the definition of it before using it
+
+Signed-off-by: Andi Shyti <andi@etezian.org>
+---
+ ioctls/videodev2.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/ioctls/videodev2.c b/ioctls/videodev2.c
+index 0d1473e..03a5ae5 100644
+--- a/ioctls/videodev2.c
++++ b/ioctls/videodev2.c
+@@ -69,7 +69,9 @@ static const struct ioctl videodev2_ioctls[] = {
+ IOCTL(VIDIOC_TRY_ENCODER_CMD),
+ IOCTL(VIDIOC_DBG_S_REGISTER),
+ IOCTL(VIDIOC_DBG_G_REGISTER),
++#ifdef VIDIOC_DBG_G_CHIP_IDENT
+ IOCTL(VIDIOC_DBG_G_CHIP_IDENT),
++#endif
+ IOCTL(VIDIOC_S_HW_FREQ_SEEK),
+ #ifdef VIDIOC_ENUM_DV_PRESETS
+ IOCTL(VIDIOC_ENUM_DV_PRESETS),
+--
+1.8.3.2
+
diff --git a/dev-util/trinity/files/trinity-1.4-flags.patch b/dev-util/trinity/files/trinity-1.4-flags.patch
new file mode 100644
index 000000000000..5b639598044a
--- /dev/null
+++ b/dev-util/trinity/files/trinity-1.4-flags.patch
@@ -0,0 +1,20 @@
+--- trinity-1.4/Makefile
++++ trinity-1.4/Makefile
+@@ -9,7 +9,7 @@
+ CC := $(CROSS_COMPILE)$(CC)
+ LD := $(CROSS_COMPILE)$(LD)
+
+-CFLAGS += -Wall -W -g -O2 -I. -Iinclude/ -Wimplicit -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -D__linux__
++CFLAGS += -Wall -W -I. -Iinclude/ -Wimplicit -D_GNU_SOURCE -D__linux__
+ ifneq ($(SYSROOT),)
+ CFLAGS += --sysroot=$(SYSROOT)
+ endif
+@@ -84,7 +84,7 @@
+ df = $(DEPDIR)/$(*D)/$(*F)
+
+ %.o : %.c
+- $(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o $@ -c $<
++ $(QUIET_CC)$(CC) $(CFLAGS) -o $@ -c $<
+ @mkdir -p $(DEPDIR)/$(*D)
+ @$(CC) -MM $(CFLAGS) $*.c > $(df).d
+ @mv -f $(df).d $(df).d.tmp
diff --git a/dev-util/trinity/files/trinity-1.5-flags.patch b/dev-util/trinity/files/trinity-1.5-flags.patch
new file mode 100644
index 000000000000..bb48287e1d83
--- /dev/null
+++ b/dev-util/trinity/files/trinity-1.5-flags.patch
@@ -0,0 +1,11 @@
+--- trinity-1.5/Makefile
++++ trinity-1.5/Makefile
+@@ -10,7 +10,7 @@
+ CC := $(CROSS_COMPILE)$(CC)
+ LD := $(CROSS_COMPILE)$(LD)
+
+-CFLAGS += -Wall -W -g -O2 -I. -Iinclude/ -Wimplicit -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -D__linux__
++CFLAGS += -Wall -W -I. -Iinclude/ -Wimplicit -D_GNU_SOURCE -D__linux__
+ ifneq ($(SYSROOT),)
+ CFLAGS += --sysroot=$(SYSROOT)
+ endif