summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-04-08 19:20:18 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-04-08 19:21:47 +0100
commit27637b60bff65066f0d0823aaddcdb78a65c2ca7 (patch)
treeb7c7f403f09e99d2d168839b8cfb3208533c8551 /dev-util/tup
parentnet-wireless/hostapd: drop old versions (diff)
downloadgentoo-27637b60bff65066f0d0823aaddcdb78a65c2ca7.tar.gz
gentoo-27637b60bff65066f0d0823aaddcdb78a65c2ca7.tar.bz2
gentoo-27637b60bff65066f0d0823aaddcdb78a65c2ca7.zip
dev-util/tup: drop old version 0.7.7
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-util/tup')
-rw-r--r--dev-util/tup/Manifest1
-rw-r--r--dev-util/tup/tup-0.7.7.ebuild103
2 files changed, 0 insertions, 104 deletions
diff --git a/dev-util/tup/Manifest b/dev-util/tup/Manifest
index c6e20f057ed5..5824be2f57f5 100644
--- a/dev-util/tup/Manifest
+++ b/dev-util/tup/Manifest
@@ -1,2 +1 @@
-DIST tup-0.7.7.tar.gz 4033539 BLAKE2B dc4d3fc538c76dac53629991e32de7414f35877af8bb9f2ce4a1f80252317de7b3d2ea1542ab3e58702813b297a42c95610d14122496ac7f23acc1f8f3d62461 SHA512 05407cc923b898d5dcf6652df6395e7618d43fa4e3ace905dda09bcda26f975187761a704d360fceeb38332f29d65cd3d1f9e04c87d93dcffa4e9e2be9b35aad
DIST tup-0.7.8.tar.gz 4540974 BLAKE2B b6724113fac9920b029604af3bf4fd875c1651b89b6c772bfecef9e8d9612574265fafd0a8eac217a51e3b3fe1d4776e97174d4c89cbf97ee3203dddc0e53f6c SHA512 17d4b76c508749ca011b3c0209bc779d617a091ed2d067bf1095fc840f62ac23145071395892170390ac6217f18bcaabb0cff582aa782838eab190244313d7f5
diff --git a/dev-util/tup/tup-0.7.7.ebuild b/dev-util/tup/tup-0.7.7.ebuild
deleted file mode 100644
index 194cf670515f..000000000000
--- a/dev-util/tup/tup-0.7.7.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="A file-based build system"
-HOMEPAGE="http://gittup.org/tup"
-# Tup itself is GPLv2, but it bundles differently licensed software:
-# - lua: MIT
-# - sqlite (unused in this ebuild): public domain
-# - inih: 3-clause BSD
-# - red-black tree implementation: 2-clause BSD
-# - queue implementation: 3-clause BSD
-LICENSE="GPL-2 MIT public-domain BSD BSD-2"
-SLOT="0"
-
-if [[ "${PV}" == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/gittup/tup.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/gittup/tup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DEPEND="
- dev-db/sqlite:=
- sys-fs/fuse:=
-"
-RDEPEND="${DEPEND}"
-
-CONFIG_CHECK="~FUSE_FS ~NAMESPACES"
-WARNING_FUSE_FS="CONFIG_FUSE_FS is required for tup to work"
-WARNING_NAMESPACES="CONFIG_NAMESPACES is required for tup to work as intended (workaround: set TUP_NO_NAMESPACING env var when running tup)"
-
-src_prepare() {
- # Use our toolchain
- sed -i Tuprules.tup \
- -e "s:CC = gcc:CC = $(tc-getCC) ${CFLAGS} ${LDFLAGS}:" \
- -e "s:ar crs:$(tc-getAR) crs:"
-
- if [[ ${PV} != 9999 ]]; then
- # Avoid invoking `git` to find version, use ours
- sed -i src/tup/link.sh \
- -e 's;`git describe`;v'"${PV};"
- fi
-
- default
-}
-
-src_configure () {
- echo "CONFIG_TUP_USE_SYSTEM_SQLITE=y" >> tup.config
-}
-
-src_compile() {
- # Disabling namespacing because it leads to accessing /proc/<pid>/setgroups
- # which violates sandboxing.
- export TUP_NO_NAMESPACING=1
- ./bootstrap-nofuse.sh || die
- unset TUP_NO_NAMESPACING
-}
-
-src_install() {
- dobin tup
- dolib.a libtup_client.a
- doheader tup_client.h
- doman tup.1
-}
-
-src_test() {
- [[ -e /dev/fuse ]] || die "/dev/fuse is required for tests to work"
- # tup uses fuse when tracking dependencies.
- addwrite /dev/fuse
-
- # Disabling namespacing because it leads to accessing /proc/<pid>/setgroups
- # which violates sandboxing.
- export TUP_NO_NAMESPACING=1
-
- # Skip tests which require namespacing or root privileges.
- SKIPPED_TESTS=(
- t4062-full-deps.sh
- t4063-full-deps2.sh
- t4064-full-deps3.sh
- t4065-full-deps-proc.sh
- t4067-full-deps5.sh
- t4069-gcc-coverage.sh
- t4072-proc-self.sh
- t4074-getpwd.sh
- t4131-proc-self-exe.sh
- t4132-proc-meminfo.sh
- t4171-dev-null.sh
- t5083-symlink-fullpath.sh
- t5084-symlink-fullpath2.sh
- t7048-full-deps.sh
- )
- pushd test || die
- rm ${SKIPPED_TESTS[@]} || die
- ./test.sh || die
- popd || die
-
- unset TUP_NO_NAMESPACING
-}