summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-05-17 20:30:29 +0200
committerFabian Groffen <grobian@gentoo.org>2018-05-17 20:30:29 +0200
commit0899b87df21dbdc4b85b9bff65aead5bafa80c8b (patch)
tree073b6a0ba8d1ef6b37e5e51a8a2d952c78c04527 /dev-util/uncrustify/uncrustify-0.67.ebuild
parentnet-vpn/tor: version bump to 0.3.4.1_alpha, new alpha branch (diff)
downloadgentoo-0899b87df21dbdc4b85b9bff65aead5bafa80c8b.tar.gz
gentoo-0899b87df21dbdc4b85b9bff65aead5bafa80c8b.tar.bz2
gentoo-0899b87df21dbdc4b85b9bff65aead5bafa80c8b.zip
dev-util/uncrustify: version bump to 0.67
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/uncrustify/uncrustify-0.67.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-0.67.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.67.ebuild b/dev-util/uncrustify/uncrustify-0.67.ebuild
new file mode 100644
index 000000000000..0b66873c7057
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.67.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ $PV == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI=""
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+python_test() {
+ cd tests
+ ${EPYTHON} run_tests.py || die "tests failed"
+}