summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-05-13 20:23:57 +0200
committerFabian Groffen <grobian@gentoo.org>2019-05-13 20:23:57 +0200
commit2611a2ee36a2930a72cb3b054551e6bcd0d24280 (patch)
treef37c4eebdce600d39cbe5fdc729a715ad8564ba6 /dev-util/uncrustify/uncrustify-0.69.0.ebuild
parentapp-admin/consul: update init script copyright (diff)
downloadgentoo-2611a2ee36a2930a72cb3b054551e6bcd0d24280.tar.gz
gentoo-2611a2ee36a2930a72cb3b054551e6bcd0d24280.tar.bz2
gentoo-2611a2ee36a2930a72cb3b054551e6bcd0d24280.zip
dev-util/uncrustify: version bump to v0.69.0
Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-util/uncrustify/uncrustify-0.69.0.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-0.69.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.69.0.ebuild b/dev-util/uncrustify/uncrustify-0.69.0.ebuild
new file mode 100644
index 000000000000..c7801da62f74
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.69.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ $PV == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+python_test() {
+ cd tests
+ ${EPYTHON} run_tests.py || die "tests failed"
+}