summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-05-14 10:42:21 +0200
committerFabian Groffen <grobian@gentoo.org>2020-05-14 10:42:21 +0200
commita3dfb216a329027a48c91f6f2562b5c90950eb72 (patch)
treeab137f974f1652ec588348e7bc313cf51d700feb /dev-util/uncrustify/uncrustify-0.71.0.ebuild
parentdev-python/zipp: x86 stable wrt bug #720662 (diff)
downloadgentoo-a3dfb216a329027a48c91f6f2562b5c90950eb72.tar.gz
gentoo-a3dfb216a329027a48c91f6f2562b5c90950eb72.tar.bz2
gentoo-a3dfb216a329027a48c91f6f2562b5c90950eb72.zip
dev-util/uncrustify-0.71.0: version bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-util/uncrustify/uncrustify-0.71.0.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-0.71.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.71.0.ebuild b/dev-util/uncrustify/uncrustify-0.71.0.ebuild
new file mode 100644
index 000000000000..ffb8d0941d9f
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.71.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ $PV == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"