summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-11-19 10:18:03 +0300
committerAmy Liffey <amynka@gentoo.org>2017-11-20 23:49:48 +0100
commitf6bff5513b4ae3376731a45c6977ecd11b5f93ff (patch)
tree521aff7e65a27ca76239713f0d908853af27ed43 /dev-util/vint
parentsys-libs/glibc: drop unused files: nscd and nsswitch.conf (diff)
downloadgentoo-f6bff5513b4ae3376731a45c6977ecd11b5f93ff.tar.gz
gentoo-f6bff5513b4ae3376731a45c6977ecd11b5f93ff.tar.bz2
gentoo-f6bff5513b4ae3376731a45c6977ecd11b5f93ff.zip
dev-util/vint: verbump to 0.3.16
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-util/vint')
-rw-r--r--dev-util/vint/Manifest1
-rw-r--r--dev-util/vint/vint-0.3.16.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/vint/Manifest b/dev-util/vint/Manifest
index 127d1d211d48..b1923ac3f66e 100644
--- a/dev-util/vint/Manifest
+++ b/dev-util/vint/Manifest
@@ -1,2 +1,3 @@
DIST vint-0.3.13.tar.gz 91599 SHA256 7cb00bf3d83a093857db9a9bcc7d316a9fa52704cbeff991130eb34ed2d27df5 SHA512 ef0b811df0250899e23e30ee4b240cf8b54e510231353ca86202661fd5f0826b9faeacc9268849e51bd6a1c71c1514498dec04a7a4ed79f00a5098811525e3d4 WHIRLPOOL 0c0a12c8a17ac2a4ab664b8aee03597a5e77b8a6b03458d4767c841d3adc03955bcbb0f876de09b2c4e194a94c9ab1d162a1902b6e49b146c4d8493ffe750e2d
DIST vint-0.3.14.tar.gz 92565 SHA256 4e0792cf83ef65ca83e09d6b3fe715cd397d635bc8380eb42302fb05d542014e SHA512 61509320e11d410cad56368fcc92d7596bd3e090dfb3950ba01886c37c3b83af69c168a71aeeb0e3221a9802a8e878a4b04a5aa6069189c5027ec1ad7070799b WHIRLPOOL 98bbf8ad3b1572a25fc6c22fad9a1b16bdfae6bfe915a30fb0f765f8a8dca2c854660a779bedf137cdd641d919cff910f38a9ccaa0879863507b5e2796601b8e
+DIST vint-0.3.16.tar.gz 94562 SHA256 1710dd4a8f363c8beca47206178eb1076e2a8e42cbaac61a6749c027a2f1534c SHA512 53bc8077e710cea8356abc6cef06ceb9503db9d4a06b59f5fad724b6aebd3c97665e1e9454b1564f7f2b483e10f7cfcb5230cc679777ffeee1ce3d54a981ff6f WHIRLPOOL 93521b25497045f6710903419bd66d1066811f9648e591fa0742c7f4b1727aa56b0f491563f2363be825a79ed63f558cf006b4b5273a5747e713315dc0c1fdee
diff --git a/dev-util/vint/vint-0.3.16.ebuild b/dev-util/vint/vint-0.3.16.ebuild
new file mode 100644
index 000000000000..e7ba6712d64d
--- /dev/null
+++ b/dev-util/vint/vint-0.3.16.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lint tool for Vim script language"
+HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.python.org/pypi/vim-vint/"
+SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ virtual/python-typing[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Don't try to use an installed vint executable.
+ # See https://github.com/Kuniwak/vint/issues/22
+ sed -i -e "s|'vint'|'bin/vint'|" test/acceptance/test_cli{,_vital}.py || die
+}
+
+python_test() {
+ py.test -v || die "Test suite failed with ${EPYTHON}"
+}