summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Jäkel <g.jaekel@dnb.de>2018-05-08 13:00:04 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-05-29 22:26:09 +0200
commita61991f7ba6b1af9bb69f0c82a4e6510774345b6 (patch)
tree308fe95e38861e708d01c522cd6aea8c63eaa1b1 /dev-util/visualvm
parentapp-text/recode: update HOMEPAGE. (diff)
downloadgentoo-a61991f7ba6b1af9bb69f0c82a4e6510774345b6.tar.gz
gentoo-a61991f7ba6b1af9bb69f0c82a4e6510774345b6.tar.bz2
gentoo-a61991f7ba6b1af9bb69f0c82a4e6510774345b6.zip
dev-util/visualvm: version bump.
Derived from visualvm-1.3.9.ebuild. This time, the Netbeans platform archive is included in the main archive upstream. Closes: https://github.com/gentoo/gentoo/pull/8316
Diffstat (limited to 'dev-util/visualvm')
-rw-r--r--dev-util/visualvm/Manifest1
-rw-r--r--dev-util/visualvm/visualvm-1.4.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/visualvm/Manifest b/dev-util/visualvm/Manifest
index 04645c28c485..17e25d96eae2 100644
--- a/dev-util/visualvm/Manifest
+++ b/dev-util/visualvm/Manifest
@@ -1,2 +1,3 @@
DIST nb802_visualvm_02102016.zip 23257637 BLAKE2B b18570b69a646c975c4b93028438cb7827f82e4e8d7d02bd11a76faf2a40164b9171626a1bd3b0664a216a30e27ff8b14d68941c8eff92e426fb92a45fb95687 SHA512 e33dba0cdfb509e9351fac343a4fbec07d3a893b6f484d0aeab972aefe41b061422dba8695003c6ca33db52d5be2f4ce218ea4fc7129f67dbd48c991c35349b5
DIST visualvm-1.3.9.tar.gz 3623394 BLAKE2B 8132447427b4abd206a825b4ce45ac54055cbb761a03624438baed7f58decb370d36bd13bb233638daad55086e04e01502b971fd0c95a31648a5b0795d8eb30f SHA512 580e2f3dd7cab1f71c8ae3004101c1067d04a7b4c164e6a59bbe95ca927dd275b8b4389e724cb7d8b38586986762126f261abc1779fb229a778c1c8db0f20387
+DIST visualvm-1.4.1.tar.gz 56752632 BLAKE2B cd171a48a0a9af440c27f2968ce27c5f89af3769046258629ba384ebbfc1c2ecb9847678af9d69bea5847fe1098e9039f35d350fb6f5d112e9236a6510c52bc7 SHA512 de8cf37e619e15c3a30c5116d49becddc09b54062aa22709e412892cf78e3048777116a8388dc6f63609d11bfb6fe37176fe48f5e3263a4dbce8439df676ef15
diff --git a/dev-util/visualvm/visualvm-1.4.1.ebuild b/dev-util/visualvm/visualvm-1.4.1.ebuild
new file mode 100644
index 000000000000..b29eb860b654
--- /dev/null
+++ b/dev-util/visualvm/visualvm-1.4.1.ebuild
@@ -0,0 +1,65 @@
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+NBV=90
+NBT=24042018
+NBZ=nb${NBV}_${PN}_${NBT}.zip
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Integrates commandline JDK tools and profiling capabilities"
+HOMEPAGE="https://visualvm.github.io"
+
+# Netbeans plattform is already included in the main archive this time
+# SRC_URI="https://github.com/oracle/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+# https://github.com/oracle/${PN}/releases/download/${PV}/${NBZ}"
+SRC_URI="https://github.com/oracle/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="7"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=virtual/jre-1.7"
+
+DEPEND="
+ >=virtual/jdk-1.7"
+
+S="${WORKDIR}/${P}/${PN}"
+
+EANT_BUILD_TARGET=build
+INSTALL_DIR=/usr/share/${PN}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}" || die
+ # unpack ${NBZ}
+ unpack ${S}/${NBZ} # archive is included in the main archive
+}
+
+src_prepare() {
+ default
+
+ # Remove unneeded binaries
+ rm -rv netbeans/platform/lib/*.{dll,exe} \
+ netbeans/platform/modules/lib/{amd64/*.dll,i386,x86} || die
+ find netbeans/profiler/lib/deployed/jdk1? -mindepth 1 \
+ -maxdepth 1 ! -name linux-amd64 -exec rm -rv {} + || die
+}
+
+src_install() {
+ # this is the visualvm cluster
+ insinto ${INSTALL_DIR}
+ doins -r build/cluster netbeans/{platform,profiler}
+
+ # configuration file that can be used to tweak visualvm startup parameters
+ insinto /etc/${PN}
+ newins "${FILESDIR}"/${PN}-r1.conf ${PN}.conf
+
+ # visualvm runtime script
+ newbin "${FILESDIR}"/${PN}-r1.sh ${PN}
+
+ # makes visualvm entry
+ make_desktop_entry ${PN} VisualVM java "Development;Java;"
+}