summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-16 15:51:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-16 15:51:46 +0100
commit45eb8e78e207e04ce46f9ce9975452e4063d5b14 (patch)
treecf57df2286a7e55868749d7ce34585b4d0ebc0dd /dev-util/wstool
parentdev-python/urllib3: Update HOMEPAGE (diff)
downloadgentoo-45eb8e78e207e04ce46f9ce9975452e4063d5b14.tar.gz
gentoo-45eb8e78e207e04ce46f9ce9975452e4063d5b14.tar.bz2
gentoo-45eb8e78e207e04ce46f9ce9975452e4063d5b14.zip
dev-util/wstool: Bump to 0.1.18.
Add python 3.7. Remove broken patch that causes zsh completion to go in the wrong dir. Closes: https://bugs.gentoo.org/693248 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-util/wstool')
-rw-r--r--dev-util/wstool/Manifest1
-rw-r--r--dev-util/wstool/wstool-0.1.18.ebuild61
-rw-r--r--dev-util/wstool/wstool-9999.ebuild3
3 files changed, 63 insertions, 2 deletions
diff --git a/dev-util/wstool/Manifest b/dev-util/wstool/Manifest
index db5883917c27..235a4850546e 100644
--- a/dev-util/wstool/Manifest
+++ b/dev-util/wstool/Manifest
@@ -1,2 +1,3 @@
DIST wstool-0.1.13.tar.gz 75188 BLAKE2B 6a34aa04e4a076a75dacf24faf789d5295f6ad9afbbdddae480d8cdd11db63940faeca2c5936a2432aeccae5274e2e9e4e824f303460fe96f95c0d17abeeb9c1 SHA512 4d54f78ca044d31d927de1c3387536d0447ece77672c555845adf54e47f07adb67e6e9c866bc2719aae468aeeb26c900b3784e0ec7cf014c8118e841a92dca14
DIST wstool-0.1.17.tar.gz 76168 BLAKE2B 4862df0ff16a5102e42d3ed683dbd9e8eb432aaf44f6e641fba6bb6f5d962645685b0fc9ca11f3c8adbe15dbef33086b93e3f9136073f7f181b5da37522e28fa SHA512 13533354a40723137baadc125425a2ec3d6a441da4870f04a9e17c53509ee4d3dc27df1a59edc2c3985a05fbd66a045539e9814f73509ee527fb763f8a804626
+DIST wstool-0.1.18.tar.gz 80595 BLAKE2B ed90fc5c63ab5d775dfb49ddacc6da6e285aeb5078cf471c0d504659a9e322fde27797e4d05fd56dff4b9958558200cf05e46cf7ae71fd1231ab63048e668808 SHA512 fda9c679183c605048ed024a57b07fd2d9b644978a3e4ff89c3716b74d8e4ba0124779bcdf88a75fdbbf47c765b7ab63db7c84a55a6e1744fc6f955649590c48
diff --git a/dev-util/wstool/wstool-0.1.18.ebuild b/dev-util/wstool/wstool-0.1.18.ebuild
new file mode 100644
index 000000000000..6754566435f6
--- /dev/null
+++ b/dev-util/wstool/wstool-0.1.18.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}
diff --git a/dev-util/wstool/wstool-9999.ebuild b/dev-util/wstool/wstool-9999.ebuild
index 44cd350a809f..6754566435f6 100644
--- a/dev-util/wstool/wstool-9999.ebuild
+++ b/dev-util/wstool/wstool-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -45,7 +45,6 @@ DEPEND="${RDEPEND}
)
"
-PATCHES=( "${FILESDIR}/prefix2.patch" )
DISTUTILS_IN_SOURCE_BUILD="yes"
python_test() {